<!DOCTYPE html>
<html lang="en-US"
      prefix="og: http://ogp.me/ns#">
<head>
  <meta charset="UTF-8">
  <meta name="viewport" content="width=device-width, initial-scale=1">
  <link rel="profile" href="https://gmpg.org/xfn/11">
  <title>Fatal Hit and Run Occurs in Culver City - WestsideToday</title>
            <script type="text/javascript"> var epic_ajax_url = 'https://westsidetoday.com/?epic-ajax-request=epic-ne'; </script>
            
<!-- This site is optimized with the Yoast SEO plugin v12.2 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://westsidetoday.com/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Fatal Hit and Run Occurs in Culver City - WestsideToday" />
<meta property="og:description" content="Suspect still at large in Sunday incident By Sam Catanzaro Over the weekend a man was killed in a hit..." />
<meta property="og:url" content="https://westsidetoday.com/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/" />
<meta property="og:site_name" content="WestsideToday" />
<meta property="article:publisher" content="https://www.facebook.com/WestsideToday" />
<meta property="article:tag" content="CCFD" />
<meta property="article:tag" content="CCPD" />
<meta property="article:tag" content="culver city" />
<meta property="article:tag" content="Culver City Fire Department" />
<meta property="article:tag" content="Culver City News" />
<meta property="article:tag" content="Culver City Police Department" />
<meta property="article:tag" content="hit-and-run" />
<meta property="article:section" content="Featured" />
<meta property="article:published_time" content="2019-11-05T16:47:14+00:00" />
<meta property="article:modified_time" content="2019-11-06T00:23:08+00:00" />
<meta property="og:updated_time" content="2019-11-06T00:23:08+00:00" />
<meta property="og:image" content="https://westsidetoday.com/wp-content/uploads/2019/11/Culver-Hit-and-Run.jpg" />
<meta property="og:image:secure_url" content="https://westsidetoday.com/wp-content/uploads/2019/11/Culver-Hit-and-Run.jpg" />
<meta property="og:image:width" content="900" />
<meta property="og:image:height" content="547" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Suspect still at large in Sunday incident By Sam Catanzaro Over the weekend a man was killed in a hit..." />
<meta name="twitter:title" content="Fatal Hit and Run Occurs in Culver City - WestsideToday" />
<meta name="twitter:site" content="@Westside_Today" />
<meta name="twitter:image" content="https://westsidetoday.com/wp-content/uploads/2019/11/Culver-Hit-and-Run.jpg" />
<meta name="twitter:creator" content="@Westside_Today" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://westsidetoday.com/#organization","name":"Westside Today","url":"https://westsidetoday.com/","sameAs":["https://www.facebook.com/WestsideToday","https://www.instagram.com/westsidelatoday/","https://www.youtube.com/user/WestsideToday","https://twitter.com/Westside_Today"],"logo":{"@type":"ImageObject","@id":"https://westsidetoday.com/#logo","url":"https://westsidetoday.com/wp-content/uploads/2014/01/wst-logo.png","width":500,"height":69,"caption":"Westside Today"},"image":{"@id":"https://westsidetoday.com/#logo"}},{"@type":"WebSite","@id":"https://westsidetoday.com/#website","url":"https://westsidetoday.com/","name":"WestsideToday","publisher":{"@id":"https://westsidetoday.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://westsidetoday.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://westsidetoday.com/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/#primaryimage","url":"https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM.png","width":1071,"height":600},{"@type":"WebPage","@id":"https://westsidetoday.com/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/#webpage","url":"https://westsidetoday.com/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/","inLanguage":"en-US","name":"Fatal Hit and Run Occurs in Culver City - WestsideToday","isPartOf":{"@id":"https://westsidetoday.com/#website"},"primaryImageOfPage":{"@id":"https://westsidetoday.com/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/#primaryimage"},"datePublished":"2019-11-05T16:47:14+00:00","dateModified":"2019-11-06T00:23:08+00:00"},{"@type":"Article","@id":"https://westsidetoday.com/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/#article","isPartOf":{"@id":"https://westsidetoday.com/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/#webpage"},"author":{"@id":"https://westsidetoday.com/#/schema/person/10f80ab2c36ea19386e25fa3e4a00562"},"headline":"Fatal Hit and Run Occurs in Culver City","datePublished":"2019-11-05T16:47:14+00:00","dateModified":"2019-11-06T00:23:08+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://westsidetoday.com/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/#webpage"},"publisher":{"@id":"https://westsidetoday.com/#organization"},"image":{"@id":"https://westsidetoday.com/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/#primaryimage"},"keywords":"CCFD,CCPD,culver city,Culver City Fire Department,Culver City News,Culver City Police Department,hit-and-run","articleSection":"Crime + Courts,Culver City,Featured,News"},{"@type":["Person"],"@id":"https://westsidetoday.com/#/schema/person/10f80ab2c36ea19386e25fa3e4a00562","name":"Sam Catanzaro","image":{"@type":"ImageObject","@id":"https://westsidetoday.com/#authorlogo","url":"https://secure.gravatar.com/avatar/1457ef4a07d2d28da24d44615fcd30b1?s=96&d=mm&r=g","caption":"Sam Catanzaro"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WestsideToday &raquo; Feed" href="https://westsidetoday.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="WestsideToday &raquo; Comments Feed" href="https://westsidetoday.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="WestsideToday &raquo; Fatal Hit and Run Occurs in Culver City Comments Feed" href="https://westsidetoday.com/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/feed/" />
      <!-- facebook -->
      <meta property="og:type" content="article"/>
      <meta property="og:title" content="Fatal Hit and Run Occurs in Culver City"/>
      <meta property="og:description" content="Suspect still at large in Sunday incident By Sam Catanzaro Over the weekend a man was killed in a hit..."/>
      <meta property="og:url" content="https://westsidetoday.com/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/"/>
      <meta property="og:image" content="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM-1024x574.png"/>
      <meta property="og:site_name" content="WestsideToday"/>
      <!-- twitter -->
      <meta name="twitter:card" content="summary" />
      <meta name="twitter:title" content="Fatal Hit and Run Occurs in Culver City" />
      <meta name="twitter:description" content="Suspect still at large in Sunday incident By Sam Catanzaro Over the weekend a man was killed in a hit..." />
      <meta name="twitter:url" content="https://westsidetoday.com/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/" />
      <meta name="twitter:image" content="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM-1024x574.png" />
    <link rel='stylesheet' id='wp-block-library-css'  href='https://westsidetoday.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='ctct_form_styles-css'  href='https://westsidetoday.com/wp-content/plugins/constant-contact-forms/assets/css/style.css?ver=1.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='smls-fontawesome-style-css'  href='https://westsidetoday.com/wp-content/plugins/smart-logo-showcase-lite/css/font-awesome.min.css?ver=1.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='smls-google-fonts-sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C300%2C600%2C700%2C800&#038;ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='smls-google-fonts-roboto-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A400%2C300italic%2C400italic%2C500%2C500italic%2C700%2C700italic%2C900italic%2C900&#038;ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='smls-google-fonts-lato-css'  href='https://fonts.googleapis.com/css?family=Lato%3A400%2C300italic%2C400italic%2C700%2C700italic%2C900italic%2C900&#038;ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='smls-google-fonts-montserrat-css'  href='https://fonts.googleapis.com/css?family=Montserrat%3A400%2C700&#038;ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='smls-google-fonts-merriweather-css'  href='https://fonts.googleapis.com/css?family=Merriweather+Sans%3A300%2C400%2C700%2C800+Sans%3A300%2C400%2C700&#038;ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='smls-google-fonts-droid-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3A400%2C700&#038;ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='smls-google-fonts-oxygen-css'  href='https://fonts.googleapis.com/css?family=Oxygen%3A300%2C400%2C700&#038;ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='smls-google-fonts-raleway-css'  href='https://fonts.googleapis.com/css?family=Raleway%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900&#038;ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='smls-owl-style-css'  href='https://westsidetoday.com/wp-content/plugins/smart-logo-showcase-lite/css/owl.carousel.css?ver=1.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='smls-tooltip-style-css'  href='https://westsidetoday.com/wp-content/plugins/smart-logo-showcase-lite/css/tooltipster.bundle.css?ver=1.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='smls-frontend-style-css'  href='https://westsidetoday.com/wp-content/plugins/smart-logo-showcase-lite/css/smls-frontend-style.css?ver=1.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='smls-responsive-style-css'  href='https://westsidetoday.com/wp-content/plugins/smart-logo-showcase-lite/css/smls-responsive.css?ver=1.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='balaton-weart-fonts-css'  href='https://fonts.googleapis.com/css?family=Playfair+Display%3A700%7CMontserrat%3A600%2C800%7CLora%3A400%2C400i%2C700%2C700i&#038;subset' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-free-css'  href='https://westsidetoday.com/wp-content/themes/balaton/assets/fontawesome/css/all.css' type='text/css' media='all' />
<link rel='stylesheet' id='balaton-weart-min-css'  href='https://westsidetoday.com/wp-content/themes/balaton/assets/weart.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='balaton-style-css'  href='https://westsidetoday.com/wp-content/themes/balaton/style.css?ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='main-style-css'  href='https://westsidetoday.com/wp-content/themes/balaton/style.css?ver=5.2.3' type='text/css' media='all' />
<style id='main-style-inline-css' type='text/css'>

          ::selection { background: #fe0100  !important }
          .article-inner:before{ background: linear-gradient(135deg, rgba(255, 255, 255, 0) 0%, #fe0100 100%) }
          .c-1, .l-1 a, .lh-1 a:hover, #weart_balaton_theme a:hover, .btn-outline-dark, .woocommerce .sidebar .button, .woocommerce-page .sidebar .button,.carousel-indicators li.active .title,
          .sidebar .box .sidebar-title *,
          .main .carousel-indicators li.active .title { color: #fe0100 !important }

          .woocommerce ul.products li.product span.onsale, .woocommerce-page ul.products li.product span.onsale,
          .woocommerce div.product span.onsale, .woocommerce-page div.product span.onsale,
          .woocommerce div.product form.cart button.button, .woocommerce-page div.product form.cart button.button,
          .woocommerce .sidebar .widget_price_filter .price_slider_wrapper .ui-slider-range, .woocommerce-page .sidebar .widget_price_filter .price_slider_wrapper .ui-slider-range,
          .woocommerce .wc-proceed-to-checkout a.checkout-button,
          .woocommerce .wc-proceed-to-checkout a.checkout-button:hover, .woocommerce-page .wc-proceed-to-checkout a.checkout-button,
          .woocommerce-page .wc-proceed-to-checkout a.checkout-button:hover,
          .woocommerce .place-order .button.alt,
          .woocommerce .place-order .button.alt:hover, .woocommerce .wc-proceed-to-checkout .button.alt,
          .woocommerce .wc-proceed-to-checkout .button.alt:hover, .woocommerce-page .place-order .button.alt,
          .woocommerce-page .place-order .button.alt:hover, .woocommerce-page .wc-proceed-to-checkout .button.alt,
          .woocommerce-page .wc-proceed-to-checkout .button.alt:hover ,
          .bg-1 { background-color: #fe0100 !important }

          .brd-1, .woocommerce .woocommerce-info, .woocommerce .woocommerce-notice, .woocommerce-page .woocommerce-info, .woocommerce-page .woocommerce-notice{ border-color: #fe0100 !important }
                    

          .sidebar #weart-newsletter .w-input input,
          #weart-comments .comment-list .comment .comment-meta .says,
          #weart-comments .comment-list .comment .comment-meta .comment-metadata a, #weart-comments .comment-list .comment .comment-meta .comment-metadata,
          #weart-comments .comment-list .pingback .comment-meta .comment-metadata a, #weart-comments .comment-list .pingback .comment-meta .comment-metadata,
          .article-content #review p,
          .sidebar .widget_nav_menu, .sidebar .widget_categories,.sidebar .widget_archive,.sidebar .widget_pages,.sidebar .widget_meta,
          .c-meta, .sidebar .widget_rss .rss-date, .l-meta a{ color: #999999 !important; }
                    

          .woocommerce .woocommerce-pagination .page-numbers li .current, .woocommerce-page .woocommerce-pagination .page-numbers li .current,
          .woocommerce ul.products li.product .price, .woocommerce-page ul.products li.product .price,
          .woocommerce div.product p.price, .woocommerce-page div.product p.price,
          .c-black, .l-black a{ color: #080808 !important; }

          .bg-black, .article-content .post-password-form input[type=submit], .bgh-black:hover,
          .woocommerce .sidebar .widget_price_filter .price_slider_wrapper .ui-slider-handle, .woocommerce-page .sidebar .widget_price_filter .price_slider_wrapper .ui-slider-handle,
          .carousel-indicators li.active,
          .bg:after { background-color: #080808 !important; }

          .brd-black,
          .sidebar-title{border-color: #080808 !important;}

          .main .carousel-indicators li.active:after{ border-color: transparent transparent #080808 transparent; }
                    

          ::selection { color: #ffffff; }

          .article-content figure .img-caption, .article-content img .img-caption,
          .woocommerce .place-order .button.alt,
          .woocommerce .place-order .button.alt:hover, .woocommerce .wc-proceed-to-checkout .button.alt,
          .woocommerce .wc-proceed-to-checkout .button.alt:hover, .woocommerce-page .place-order .button.alt,
          .woocommerce-page .place-order .button.alt:hover, .woocommerce-page .wc-proceed-to-checkout .button.alt,
          .woocommerce-page .wc-proceed-to-checkout .button.alt:hover,
          .c-white, .article-content .post-password-form input[type=submit], .l-white a, .lh-white a:hover { color: #FFFFFF !important; }

          .video .carousel-indicators li.active,
          .bg-white { background-color: #FFFFFF !important; }

          .video .carousel-indicators li.active:after { border-color: transparent #FFFFFF transparent transparent; }
                    

          .c-text, .l-text a, .btn-outline-dark:hover, .woocommerce .sidebar .button:hover, .woocommerce-page .sidebar .button:hover{ color: #222222 !important; }

                    
</style>
<link rel='stylesheet' id='epic-icon-css'  href='https://westsidetoday.com/wp-content/plugins/epic-news-element/assets/fonts/jegicon/jegicon.css?ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://westsidetoday.com/wp-content/plugins/epic-news-element/assets/fonts/font-awesome/font-awesome.min.css?ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='epic.style-css'  href='https://westsidetoday.com/wp-content/plugins/epic-news-element/assets/css/style.min.css?ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='jeg-dynamic-style-css'  href='https://westsidetoday.com/wp-content/uploads/jeg/jeg-1wafu3EgVt.css?ver=1.0.0' type='text/css' media='all' />
<script type='text/javascript' src='https://westsidetoday.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://westsidetoday.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://westsidetoday.com/wp-content/plugins/smart-logo-showcase-lite/js/owl.carousel.js?ver=1.1.2'></script>
<script type='text/javascript' src='https://westsidetoday.com/wp-content/plugins/smart-logo-showcase-lite/js/tooltipster.bundle.js?ver=1.1.2'></script>
<script type='text/javascript' src='https://westsidetoday.com/wp-content/plugins/smart-logo-showcase-lite/js/smls-frontend-script.js?ver=1.1.2'></script>
<script type='text/javascript'>
var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://westsidetoday.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.6-78496d1'></script>
<script type='text/javascript' src='https://westsidetoday.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=5.2.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<link rel='https://api.w.org/' href='https://westsidetoday.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://westsidetoday.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://westsidetoday.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://westsidetoday.com/?p=130882' />
<link rel="alternate" type="application/json+oembed" href="https://westsidetoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwestsidetoday.com%2F2019%2F11%2F05%2Ffatal-hit-and-run-occurs-in-culver-city%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://westsidetoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwestsidetoday.com%2F2019%2F11%2F05%2Ffatal-hit-and-run-occurs-in-culver-city%2F&#038;format=xml" />
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-47795422-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-47795422-1');
</script>



<script type='text/javascript' src='//westsidetoday.com/wp-content/uploads/custom-css-js/130667.js?v=5823'></script>
		<style>
			.no-js img.lazyload { display: none; }
			figure.wp-block-image img.lazyloading { min-width: 150px; }
							.lazyload, .lazyloading { opacity: 0; }
				.lazyloaded {
					opacity: 1;
					transition: opacity 400ms;
					transition-delay: 0ms;
				}
					</style>
				<style type="text/css" id="wp-custom-css">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</style>
		<style id="tt-easy-google-font-styles" type="text/css">p { }
h1 { }
h2 { }
h3 { }
h4 { }
h5 { }
h6 { }
.f-meta,.article-content .post-password-form input[type=submit],.woocommerce .woocommerce-result-count,.woocommerce-page .woocommerce-result-count,.woocommerce .orderby,.woocommerce-page .orderby,.woocommerce .woocommerce-pagination .page-numbers,.woocommerce-page .woocommerce-pagination .page-numbers,.woocommerce ul.products li.product .price,.woocommerce-page ul.products li.product .price,.woocommerce div.product form.cart input.qty,.woocommerce-page div.product form.cart input.qty,.woocommerce div.product form.cart button.button,.woocommerce-page div.product form.cart button.button,.woocommerce div.product .woocommerce-tabs ul.tabs li,.woocommerce div.product .related ul.tabs li,.woocommerce-page div.product .woocommerce-tabs ul.tabs li,.woocommerce-page div.product .related ul.tabs li,.woocommerce .sidebar .mini_cart_item,.woocommerce .sidebar ul.product-categories,.woocommerce-page .sidebar .mini_cart_item,.woocommerce-page .sidebar ul.product-categories,.woocommerce .sidebar .woocommerce ul.cart_list li .amount,.woocommerce .sidebar .woocommerce ul.cart_list li .quantity,.woocommerce .sidebar .woocommerce ul.product_list_widget li .amount,.woocommerce .sidebar .woocommerce ul.product_list_widget li .quantity,.woocommerce-page .sidebar .woocommerce ul.cart_list li .amount,.woocommerce-page .sidebar .woocommerce ul.cart_list li .quantity,.woocommerce-page .sidebar .woocommerce ul.product_list_widget li .amount,.woocommerce-page .sidebar .woocommerce ul.product_list_widget li .quantity,.woocommerce .sidebar .woocommerce-mini-cart__total,.woocommerce-page .sidebar .woocommerce-mini-cart__total,.woocommerce .place-order .button.alt,.woocommerce .place-order .button.alt:hover,.woocommerce .wc-proceed-to-checkout .button.alt,.woocommerce .wc-proceed-to-checkout .button.alt:hover,.woocommerce-page .place-order .button.alt,.woocommerce-page .place-order .button.alt:hover,.woocommerce-page .wc-proceed-to-checkout .button.alt,.woocommerce-page .wc-proceed-to-checkout .button.alt:hover,.f-meta-nosize,.sidebar .widget_tag_cloud a,#weart-comments .comment-list .comment .comment-meta,.woocommerce ul.products li.product span.onsale,.woocommerce-page ul.products li.product span.onsale,.woocommerce div.product span.onsale,.woocommerce-page div.product span.onsale,.woocommerce div.product p.price,.woocommerce-page div.product p.price,.woocommerce .sidebar .button,.woocommerce-page .sidebar .button,.woocommerce .wc-proceed-to-checkout a.checkout-button,.woocommerce .wc-proceed-to-checkout a.checkout-button:hover,.woocommerce-page .wc-proceed-to-checkout a.checkout-button,.woocommerce-page .wc-proceed-to-checkout a.checkout-button:hover { }
.f-text,#weart-comments .comment-list .comment,.article-content #review li,.woocommerce .woocommerce-info,.woocommerce .woocommerce-notice,.woocommerce-page .woocommerce-info,.woocommerce-page .woocommerce-notice { }
.f-title,h1,.h1,h2,.h2,h3,.h3,h4,.h4,h5,.h5,.article-content #review .review-summary-title,.article-content #review .review-title,.woocommerce div.product .woocommerce-tabs h2,.woocommerce div.product .related h2,.woocommerce-page div.product .woocommerce-tabs h2,.woocommerce-page div.product .related h2,h6,.h6,.woocommerce ul.products li.product .woocommerce-loop-product__title,.woocommerce-page ul.products li.product .woocommerce-loop-product__title,.article-title,.single header .lead::first-letter,.single header .article-content blockquote p::first-letter,.article-content blockquote .single header p::first-letter,.article-content #review .review-summary-title,.article-content #review .review-title,.woocommerce .sidebar .woocommerce ul.cart_list li a,.woocommerce .sidebar .woocommerce ul.product_list_widget li a,.woocommerce-page .sidebar .woocommerce ul.cart_list li a,.woocommerce-page .sidebar .woocommerce ul.product_list_widget li a { }
</style></head>
<body  class="post-template-default single single-post postid-130882 single-format-standard wp-custom-logo epic-gutenberg ctct-balaton">
  <div class="px-lg-5 py-3" id="weart_balaton_theme">
    <div class="bg-white p-lg-5 shadow mw-weart">
<!-- mobile -->
  <div id="weart-mobile">
    <div class="inner bg-white l-black c-black f-meta text-uppercase">
      <a href="#close" class="fas fa-times bars"></a>
      <!-- menu -->
        <div class="w-menu"><ul id="menu-main" class="menu"><li id="menu-item-12" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12"><a href="/">Home</a></li>
<li id="menu-item-130699" class="weart-megamenu menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-130699"><a href="https://westsidetoday.com/news/">News</a></li>
<li id="menu-item-130700" class="weart-megamenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130700"><a href="https://westsidetoday.com/health/">Health</a></li>
<li id="menu-item-130701" class="weart-megamenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130701"><a href="https://westsidetoday.com/todo/events-exhibits/">Arts and Culture</a></li>
<li id="menu-item-130698" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130698"><a href="https://watchedify.com">WATCH EDIFY</a></li>
<li id="menu-item-130695" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-130695"><a href="https://westsidetoday.com/advertising/">Advertising</a></li>
<li id="menu-item-130697" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-130697"><a href="https://westsidetoday.com/pr-services/">PR Services</a></li>
<li id="menu-item-130696" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-130696"><a href="https://westsidetoday.com/contact-us/">Contact Us</a></li>
</ul></div>      <!-- end -->
    </div>
  </div>
<!-- end -->

<!-- fly-over --><!-- end -->

<!-- hedader_layouts -->
  
    <header>
    
    <div class="header-ad">
<script src='https://www.googletagservices.com/tag/js/gpt.js'>
  googletag.pubads().definePassback('/21621973880/westsidetoday_headerleaderboard', [728, 90]).display();
</script>
    </div>

      <div class="top pb-3 border-bottom brd-bold brd-black">
        <div class="w-logoline">
          <!-- logo -->
            <div class="logo f-meta l-black pt-3 px-3 p-lg-0" itemscope itemtype="https://schema.org/Organization">
                                <div itemscope itemtype="https://schema.org/ImageObject">
                  <a href="https://westsidetoday.com/" class="custom-logo-link" rel="home"><img width="300" height="41"   alt="WestsideToday" data-src="https://westsidetoday.com/wp-content/uploads/2019/08/cropped-wst-logo-300x41.png" class="custom-logo lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="300" height="41" src="https://westsidetoday.com/wp-content/uploads/2019/08/cropped-wst-logo-300x41.png" class="custom-logo" alt="WestsideToday" /></noscript></a>                </div>
                            <meta itemprop="name" content="WestsideToday">
            </div>
          <!-- end -->
          <div class="meta small f-text d-none d-lg-flex c-text">
            <span class="date">November 6, 2019</span>
            <span class="">The Best Source of News, Culture, Lifestyle for Culver City, Mar Vista, Del Rey,  Palms and West Los Angeles</span>
          </div>
        </div>
      </div>

      <div class="bottom d-flex c-black l-black lh-1 f-meta border-bottom minus position-relative" id="w-menu">

            <div class="w-social d-none border-right px-3"><ul id="menu-social" class="menu"><li id="menu-item-9" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9"><a href="https://www.facebook.com/WestsideToday/">facebook</a></li>
<li id="menu-item-130566" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130566"><a href="https://twitter.com/westsidelatoday?lang=en">twitter</a></li>
</ul></div>
            <!-- menu -->
              <div class="w-menu d-none d-lg-flex c-meta ml-auto"><ul id="menu-main-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12"><a href="/">Home</a></li>
<li class="weart-megamenu menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-130699"><a href="https://westsidetoday.com/news/">News</a><div class="weart-megamenu"><div class="w-100 bg-white shadow border-top"><div class="container"><div class="row"><div class="col-3 l-black py-4"><a href="https://westsidetoday.com/2019/11/05/lily-the-pink-helping-women-look-their-best/"><div class="lazy bg-20" data-src="https://westsidetoday.com/wp-content/uploads/2019/11/Lily-Pink.png"></div><span class="d-block mt-2 h6">Lily the Pink – Helping Women Look Their Best</span></a></div><div class="col-3 l-black py-4"><a href="https://westsidetoday.com/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/"><div class="lazy bg-20" data-src="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM.png"></div><span class="d-block mt-2 h6">Fatal Hit and Run Occurs in Culver City</span></a></div><div class="col-3 l-black py-4"><a href="https://westsidetoday.com/2019/11/05/edify-tv-dog-o-ween/"><div class="lazy bg-20" data-src="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-3.08.50-PM.png"></div><span class="d-block mt-2 h6">Edify TV: Dog-O-Ween</span></a></div><div class="col-3 l-black py-4"><a href="https://westsidetoday.com/2019/11/04/new-hyatt-hotel-is-beginning-construction-at-culver-city-ivy-station-helms-bakery-district-fashion-sample-sale-westside-today-news-show-november-4-2019/"><div class="lazy bg-20" data-src="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-04-at-2.19.52-PM.png"></div><span class="d-block mt-2 h6">New Hyatt hotel is beginning construction at Culver City Ivy Station, Helms Bakery district fashion sample sale: Westside Today News Show November 4, 2019</span></a></div></div></div></div></div></li>
<li class="weart-megamenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130700"><a href="https://westsidetoday.com/health/">Health</a><div class="weart-megamenu"><div class="w-100 bg-white shadow border-top"><div class="container"><div class="row"><div class="col-3 l-black py-4"><a href="https://westsidetoday.com/2019/10/15/culver-city-to-consider-banning-sale-of-flavored-vapes/"><div class="lazy bg-20" data-src="https://westsidetoday.com/wp-content/uploads/2019/10/25126975800_4729acf696_c-696x464.jpg"></div><span class="d-block mt-2 h6">Culver City to Consider Banning Sale of Flavored Vapes</span></a></div><div class="col-3 l-black py-4"><a href="https://westsidetoday.com/2019/03/06/six-cases-of-hep-c-reported-at-westside-medical-clinic/"><div class="lazy bg-20" data-src="https://westsidetoday.com/wp-content/uploads/2019/03/1HepCWestside-e1551900421234.jpg"></div><span class="d-block mt-2 h6">Six Cases of Hep C Reported at Westside Medical Clinic</span></a></div><div class="col-3 l-black py-4"><a href="https://westsidetoday.com/2019/02/28/wide-ranging-benefits-of-oxygen-therapy/"><div class="lazy bg-20" data-src="https://westsidetoday.com/wp-content/uploads/2019/02/50606659_325636594718424_1259543977535733760_o-2-e1551385895469.jpg"></div><span class="d-block mt-2 h6">Wide-Ranging Benefits of Oxygen Therapy</span></a></div><div class="col-3 l-black py-4"><a href="https://westsidetoday.com/2018/11/16/edify-tv-video-aging-healthy/"><div class="lazy bg-20" data-src="https://westsidetoday.com/wp-content/uploads/2018/11/Screen-Shot-2018-11-16-at-10.47.00-AM.png"></div><span class="d-block mt-2 h6">Edify TV Video: Aging Healthy</span></a></div></div></div></div></div></li>
<li class="weart-megamenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130701"><a href="https://westsidetoday.com/todo/events-exhibits/">Arts and Culture</a><div class="weart-megamenu"><div class="w-100 bg-white shadow border-top"><div class="container"><div class="row"><div class="col-3 l-black py-4"><a href="https://westsidetoday.com/2019/09/26/culver-citys-small-book-press-festival/"><div class="lazy bg-20" data-src="https://westsidetoday.com/wp-content/uploads/2019/10/70780305_3086698438038220_2173434372978376704_n-696x336.jpg"></div><span class="d-block mt-2 h6">Culver City&#8217;s Small Book Press Festival</span></a></div><div class="col-3 l-black py-4"><a href="https://westsidetoday.com/2019/07/23/louis-vuitton-x-an-immersive-journey-through-fashion-history/"><div class="lazy bg-20" data-src="https://westsidetoday.com/wp-content/uploads/2019/07/MG_6469.jpg"></div><span class="d-block mt-2 h6">Louis Vuitton X: An Immersive Journey Through Fashion History</span></a></div><div class="col-3 l-black py-4"><a href="https://westsidetoday.com/2019/07/23/need-a-little-growth-capital/"><div class="lazy bg-20" data-src="https://westsidetoday.com/wp-content/uploads/2019/07/1.-Judges-Panel.jpg"></div><span class="d-block mt-2 h6">Need a Little Growth Capital?</span></a></div><div class="col-3 l-black py-4"><a href="https://westsidetoday.com/2019/06/07/rogue-machine-returns-to-venice-for-a-new-season-of-live-entertainment/"><div class="lazy bg-20" data-src="https://westsidetoday.com/wp-content/uploads/2019/06/Kenney-Selvey-Randolph-Thompson-Ryan-Brophy-and-Jasmine-St.-Clair-RSYG.jpg"></div><span class="d-block mt-2 h6">Rogue Machine Returns To Venice For A New Season of Live Entertainment</span></a></div></div></div></div></div></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130698"><a href="https://watchedify.com">WATCH EDIFY</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-130695"><a href="https://westsidetoday.com/advertising/">Advertising</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-130697"><a href="https://westsidetoday.com/pr-services/">PR Services</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-130696"><a href="https://westsidetoday.com/contact-us/">Contact Us</a></li>
</ul></div>                              <div class="d-flex d-lg-none bars px-3 border-right mr-auto">
                  <a href="#menubutton">
                    <i class="fas fa-bars"></i>
                  </a>
                </div>
                          <!-- end -->

            <!-- search -->
              <div class="w-search px-3 border-left ml-auto">
                <a href="#w-search" class="search-indicator"><i class="fas fa-search"></i></a>
                <div class="search-box bg-2">
                  <form role="search" method="get" class="search-form d-block" action="https://westsidetoday.com/">
  <div class="input-group  input-group-sm">
    <input type="search" class="form-control search-field rounded-0 f-main border" placeholder="Search for..." aria-label="Search for..." name="s">
    <span class="input-group-btn">
      <button class="btn bg-1 c-white search-submit rounded-0" type="submit"><i class="fas fa-search"></i></button>
    </span>
  </div>
</form>
                </div>
              </div>
            <!-- end -->

      </div>

    </header>

  <!-- end -->

<main id="main" class="c-text f-text mb-5">
<div class="section">
<article itemscope itemtype="http://schema.org/NewsArticle" class="container mt-5">
      <meta itemscope itemprop="mainEntityOfPage" content="https://westsidetoday.com/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/" itemType="https://schema.org/WebPage" itemid="https://westsidetoday.com/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/"/>

    <!-- header -->
            <div class="row ">
        <div class="col-lg-10">
          <!-- article-header -->
            <header>
              <h1 class="article-title h1 c-black my-4" itemprop="headline">Fatal Hit and Run Occurs in Culver City</h1>
            </header>
          <!-- end -->
        </div>
      </div>
    <!-- end -->

    <!-- content-area -->
      <div class="row justify-content-center">
        <div class="col-lg-8 article-container">

          <!-- excerpt -->
                      <!-- end -->

          <!-- featured img -->
            <div class="mb-4">    <!-- featured image -->
                <div class="featured-img" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
                        <meta itemprop="url" content="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM-730x409.png">
            <meta itemprop="width" content="730">
            <meta itemprop="height" content="409">
            <img width="1071" height="600"   alt="" data-srcset="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM.png 1071w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM-300x168.png 300w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM-768x430.png 768w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM-1024x574.png 1024w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM-730x409.png 730w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM-350x196.png 350w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM-750x420.png 750w" sizes="(max-width: 1071px) 100vw, 1071px" data-src="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="1071" height="600" src="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM.png 1071w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM-300x168.png 300w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM-768x430.png 768w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM-1024x574.png 1024w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM-730x409.png 730w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM-350x196.png 350w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM-750x420.png 750w" sizes="(max-width: 1071px) 100vw, 1071px" /></noscript><div class="ccfic"><span class="ccfic-text">The area of Washington Place, west of Frances Avenue, where a fatal hit and run occurred over the weekend. Photo: Google. </span></div>          </div>
            <!-- end -->
  </div>
          <!-- end -->

          <div class="text">
            

<!-- content -->
  <div class="article-content content l-1">
    <div class="clearfix">
<p><strong>Suspect still at large in Sunday incident </strong></p>



<p><strong>By Sam Catanzaro</strong></p>



<p>Over the weekend a man was killed in a hit and run on Washington Place. At the time of publishing the suspect remains at large and Culver City police are asking the public for help identifying them. </p>



<p>On Sunday, November 3, at approximately 1:45 AM, the Culver City Police Department (CCPD) and the Culver City Fire Department (CCFD) personnel responded to the area of Washington Place, west of Frances Avenue, on a call of an injury hit and run traffic collision, involving a vehicle striking a pedestrian. According to the CCPD, upon their arrival, the responding police officers located the male victim lying on the street in the eastbound lanes of Washington Place, west of Frances Avenue. CCFD paramedics subsequently declared the victim deceased at the scene. </p>



<p>&#8220;Our officers learned that the victim had been struck by a vehicle while crossing the street and that the suspect had fled the location following the collision,&#8221; CCPD said in a press release. </p>



<p>According to the Los Angeles County Medical Examiner-Coroner, the victim was Reynaldo Martinez, a 60-year-old Hispanic male. </p>



<p>No witnesses to the collision were located during the on-scene investigation. The suspect never returned to the scene following the collision and was not identified.</p>



<p>The Culver City Police Department is asking anyone with information about this collision, the suspect, or the suspect vehicle to contact Accident Investigator Houck at (310) 253-6254 or Sergeant Loken at (310) 253-6260.</p>
</div>
    <div class="link-pages c-meta l-black f-meta clearfix">
          </div>
  </div>
<!-- end -->

<!-- share -->
    <!-- displayable meta -->
    <div class="d-block d-md-flex align-items-center justify-content-between mb-4 l-1 c-meta border-top py-3 mb-5">

      <div class="left small font-italic ">

        <div class="top d-flex">
                  <span class="author mr-1" itemprop="author" itemscope itemtype="https://schema.org/Person">
            By            <span itemprop="name"><a href="https://westsidetoday.com/author/samcatanzaro/" title="Posts by Sam Catanzaro" rel="author">Sam Catanzaro</a></span>
          </span>
        
                  <span class="date mr-1">
            <time itemprop="datePublished" datetime="2019-11-05">November 5, 2019</time>
            <meta itemprop="dateModified" content="2019-11-05"/>
          </span>
        
        </div>
        <div class="bottom">
          <span class="tags mr-1 d-inline-block">
            Tags: <a href="https://westsidetoday.com/tag/ccfd/" rel="tag">CCFD</a>, <a href="https://westsidetoday.com/tag/ccpd/" rel="tag">CCPD</a>, <a href="https://westsidetoday.com/tag/culver-city/" rel="tag">culver city</a>, <a href="https://westsidetoday.com/tag/culver-city-fire-department/" rel="tag">Culver City Fire Department</a>, <a href="https://westsidetoday.com/tag/culver-city-news/" rel="tag">Culver City News</a>, <a href="https://westsidetoday.com/tag/culver-city-police-department/" rel="tag">Culver City Police Department</a>, <a href="https://westsidetoday.com/tag/hit-and-run/" rel="tag">hit-and-run</a>          </span>

          <span class="category mr-1  d-inline-block">
            in <a href="https://westsidetoday.com/news/crime-courts/" rel="category tag">Crime + Courts</a>, <a href="https://westsidetoday.com/culver-city/" rel="category tag">Culver City</a>, <a href="https://westsidetoday.com/featured/" rel="category tag">Featured</a>, <a href="https://westsidetoday.com/news/" rel="category tag">News</a>          </span>
        </div>
      </div>

      <div class="right mt-4 mt-md-0">
          <div class="weart-share lh-white">
    <!-- facebook -->
      <a class="bgh-black" href="https://www.facebook.com/sharer/sharer.php" onclick="var sharerFb = 'https://www.facebook.com/sharer/sharer.php?u=https://westsidetoday.com/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/'; window.open(sharerFb, 'sharerFb', 'width=626,height=436'); return false;"><i class="fab fa-facebook"></i></a>
    <!-- end -->

    <!-- Twitter -->
      <a class="bgh-black" href="https://twitter.com/share" onclick="var sharerTw = 'https://twitter.com/share?text=Fatal Hit and Run Occurs in Culver City&amp;url=https://westsidetoday.com/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/'; window.open(sharerTw, 'sharerTw', 'width=550,height=520'); return false;"><i class="fab fa-twitter"></i></a>
    <!-- end -->

    <!-- Reddit -->
      <a class="bgh-black" href="https://www.reddit.com/submit" onclick="var sharerRd = 'https://www.reddit.com/submit?url=https://westsidetoday.com/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/&amp;title=Fatal Hit and Run Occurs in Culver City'; window.open(sharerRd, 'sharerRd', 'width=840,height=464'); return false;"><i class="fab fa-reddit"></i></a>
    <!-- end -->

    <!-- Tumblr -->
      <a class="bgh-black" href="https://www.tumblr.com/share" onclick="var sharerTb = 'https://www.tumblr.com/share/link?url='; window.open(sharerTb + encodeURIComponent ( location.href ), 'sharerTb', 'width=450,height=430'); return false;"><i class="fab fa-tumblr"></i></a>
    <!-- end -->
  </div>
        </div>
    </div>
  <!-- end -->

  <!-- seo publisher -->
    <div class="d-none" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
      <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
                            <meta itemprop="url" content="https://westsidetoday.com/wp-content/uploads/2019/08/cropped-wst-logo-300x41.png" >
              </div>
      <meta itemprop="name" content="WestsideToday">
    </div>
  <!-- end -->
  <!-- end -->

<!-- banner -->
      <div class="my-5 w-ads">
      <script src='https://www.googletagservices.com/tag/js/gpt.js'>  googletag.pubads().definePassback('/21621973880/westsidetoday_articlebottom', [[300, 250], [728, 90]]).display();</script>    </div>
  <!-- end -->

<!-- related -->
          <div class="meta-title text-center f-title border-bottomm  pb-2 mb-3 border-bottom h6">
      <span class="c-1">Related Posts</span>
      <hr class="brd-black brd-bold my-1">
    </div>
      
    <div class="mb-4 border-0 post-130889 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-health-fit category-lifestyle category-news">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://westsidetoday.com/2019/11/05/lily-the-pink-helping-women-look-their-best/" title="Lily the Pink – Helping Women Look Their Best">
                              <img width="730" height="486"   alt="" data-srcset="https://westsidetoday.com/wp-content/uploads/2019/11/Lily-Pink-730x486.png 730w, https://westsidetoday.com/wp-content/uploads/2019/11/Lily-Pink-300x200.png 300w, https://westsidetoday.com/wp-content/uploads/2019/11/Lily-Pink-768x511.png 768w, https://westsidetoday.com/wp-content/uploads/2019/11/Lily-Pink-1024x682.png 1024w, https://westsidetoday.com/wp-content/uploads/2019/11/Lily-Pink-350x233.png 350w, https://westsidetoday.com/wp-content/uploads/2019/11/Lily-Pink-272x182.png 272w, https://westsidetoday.com/wp-content/uploads/2019/11/Lily-Pink-750x499.png 750w, https://westsidetoday.com/wp-content/uploads/2019/11/Lily-Pink.png 1086w" sizes="(max-width: 730px) 100vw, 730px" data-src="https://westsidetoday.com/wp-content/uploads/2019/11/Lily-Pink-730x486.png" class="attachment-weart-grid size-weart-grid wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="730" height="486" src="https://westsidetoday.com/wp-content/uploads/2019/11/Lily-Pink-730x486.png" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://westsidetoday.com/wp-content/uploads/2019/11/Lily-Pink-730x486.png 730w, https://westsidetoday.com/wp-content/uploads/2019/11/Lily-Pink-300x200.png 300w, https://westsidetoday.com/wp-content/uploads/2019/11/Lily-Pink-768x511.png 768w, https://westsidetoday.com/wp-content/uploads/2019/11/Lily-Pink-1024x682.png 1024w, https://westsidetoday.com/wp-content/uploads/2019/11/Lily-Pink-350x233.png 350w, https://westsidetoday.com/wp-content/uploads/2019/11/Lily-Pink-272x182.png 272w, https://westsidetoday.com/wp-content/uploads/2019/11/Lily-Pink-750x499.png 750w, https://westsidetoday.com/wp-content/uploads/2019/11/Lily-Pink.png 1086w" sizes="(max-width: 730px) 100vw, 730px" /></noscript><div class="ccfic"></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://westsidetoday.com/featured/" rel="category tag">Featured</a>, <a href="https://westsidetoday.com/lifestyle/health-fit/" rel="category tag">Health + Fitness</a>, <a href="https://westsidetoday.com/lifestyle/" rel="category tag">Lifestyle</a>, <a href="https://westsidetoday.com/news/" rel="category tag">News</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://westsidetoday.com/2019/11/05/lily-the-pink-helping-women-look-their-best/" title="Lily the Pink – Helping Women Look Their Best">
                Lily the Pink – Helping Women Look Their Best              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">November 5, 2019</span>      <span class="author"><a href="https://westsidetoday.com/author/westsidetodaystaff/" title="Posts by Westside Today Staff" rel="author">Westside Today Staff</a></span>
          </p>

    <div class="left d-none">
      <a href="https://westsidetoday.com/2019/11/05/lily-the-pink-helping-women-look-their-best/" title="Lily the Pink – Helping Women Look Their Best">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">November 5, 2019</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">Sandy Allbright’s permanent makeup studio in Brentwood&nbsp; By Staff Writer For women who want to look their best all the...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 border-top post-130886 post type-post status-publish format-standard has-post-thumbnail hentry category-edify-tv category-featured category-news">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://westsidetoday.com/2019/11/05/edify-tv-dog-o-ween/" title="Edify TV: Dog-O-Ween">
                              <img width="730" height="407"   alt="" data-srcset="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-3.08.50-PM-730x407.png 730w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-3.08.50-PM-300x167.png 300w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-3.08.50-PM-768x428.png 768w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-3.08.50-PM-350x195.png 350w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-3.08.50-PM-750x418.png 750w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-3.08.50-PM.png 798w" sizes="(max-width: 730px) 100vw, 730px" data-src="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-3.08.50-PM-730x407.png" class="attachment-weart-grid size-weart-grid wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="730" height="407" src="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-3.08.50-PM-730x407.png" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-3.08.50-PM-730x407.png 730w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-3.08.50-PM-300x167.png 300w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-3.08.50-PM-768x428.png 768w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-3.08.50-PM-350x195.png 350w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-3.08.50-PM-750x418.png 750w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-3.08.50-PM.png 798w" sizes="(max-width: 730px) 100vw, 730px" /></noscript><div class="ccfic"></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://westsidetoday.com/edify-tv/" rel="category tag">Edify Tv</a>, <a href="https://westsidetoday.com/featured/" rel="category tag">Featured</a>, <a href="https://westsidetoday.com/news/" rel="category tag">News</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://westsidetoday.com/2019/11/05/edify-tv-dog-o-ween/" title="Edify TV: Dog-O-Ween">
                Edify TV: Dog-O-Ween              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">November 5, 2019</span>      <span class="author"><a href="https://westsidetoday.com/author/videointern/" title="Posts by Video" rel="author">Video</a></span>
          </p>

    <div class="left d-none">
      <a href="https://westsidetoday.com/2019/11/05/edify-tv-dog-o-ween/" title="Edify TV: Dog-O-Ween">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">November 5, 2019</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">Venice Dog-O-Ween was Sunday, November 3rd. Dogs and their owners walked the red carpet to show off the best Halloween...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 border-top post-130880 post type-post status-publish format-standard has-post-thumbnail hentry category-edify-tv category-featured category-news">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://westsidetoday.com/2019/11/04/new-hyatt-hotel-is-beginning-construction-at-culver-city-ivy-station-helms-bakery-district-fashion-sample-sale-westside-today-news-show-november-4-2019/" title="New Hyatt hotel is beginning construction at Culver City Ivy Station, Helms Bakery district fashion sample sale: Westside Today News Show November 4, 2019">
                              <img width="730" height="409"   alt="" data-srcset="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-04-at-2.19.52-PM-730x409.png 730w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-04-at-2.19.52-PM-300x168.png 300w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-04-at-2.19.52-PM-768x430.png 768w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-04-at-2.19.52-PM-350x196.png 350w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-04-at-2.19.52-PM-750x420.png 750w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-04-at-2.19.52-PM.png 797w" sizes="(max-width: 730px) 100vw, 730px" data-src="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-04-at-2.19.52-PM-730x409.png" class="attachment-weart-grid size-weart-grid wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="730" height="409" src="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-04-at-2.19.52-PM-730x409.png" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-04-at-2.19.52-PM-730x409.png 730w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-04-at-2.19.52-PM-300x168.png 300w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-04-at-2.19.52-PM-768x430.png 768w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-04-at-2.19.52-PM-350x196.png 350w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-04-at-2.19.52-PM-750x420.png 750w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-04-at-2.19.52-PM.png 797w" sizes="(max-width: 730px) 100vw, 730px" /></noscript><div class="ccfic"></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://westsidetoday.com/edify-tv/" rel="category tag">Edify Tv</a>, <a href="https://westsidetoday.com/featured/" rel="category tag">Featured</a>, <a href="https://westsidetoday.com/news/" rel="category tag">News</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://westsidetoday.com/2019/11/04/new-hyatt-hotel-is-beginning-construction-at-culver-city-ivy-station-helms-bakery-district-fashion-sample-sale-westside-today-news-show-november-4-2019/" title="New Hyatt hotel is beginning construction at Culver City Ivy Station, Helms Bakery district fashion sample sale: Westside Today News Show November 4, 2019">
                New Hyatt hotel is beginning construction at Culver City Ivy Station, Helms Bakery district fashion sample sale: Westside Today News Show November 4, 2019              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">November 4, 2019</span>      <span class="author"><a href="https://westsidetoday.com/author/videointern/" title="Posts by Video" rel="author">Video</a></span>
          </p>

    <div class="left d-none">
      <a href="https://westsidetoday.com/2019/11/04/new-hyatt-hotel-is-beginning-construction-at-culver-city-ivy-station-helms-bakery-district-fashion-sample-sale-westside-today-news-show-november-4-2019/" title="New Hyatt hotel is beginning construction at Culver City Ivy Station, Helms Bakery district fashion sample sale: Westside Today News Show November 4, 2019">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">November 4, 2019</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">Westside Today News Show November 4, 2019 &#8211; All your local news and happenings in under 5 minutes!* New Hyatt...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 border-top post-130874 post type-post status-publish format-standard has-post-thumbnail hentry category-culver-city category-featured category-news">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://westsidetoday.com/2019/11/04/culver-city-firefighters-movember/" title="Culver City Firefighters Movember">
                              <img width="730" height="364"   alt="" data-srcset="https://westsidetoday.com/wp-content/uploads/2019/11/CCFD-Firefighters-730x364.jpg 730w, https://westsidetoday.com/wp-content/uploads/2019/11/CCFD-Firefighters-300x150.jpg 300w, https://westsidetoday.com/wp-content/uploads/2019/11/CCFD-Firefighters-768x383.jpg 768w, https://westsidetoday.com/wp-content/uploads/2019/11/CCFD-Firefighters-350x175.jpg 350w, https://westsidetoday.com/wp-content/uploads/2019/11/CCFD-Firefighters-360x180.jpg 360w, https://westsidetoday.com/wp-content/uploads/2019/11/CCFD-Firefighters-750x374.jpg 750w, https://westsidetoday.com/wp-content/uploads/2019/11/CCFD-Firefighters.jpg 802w" sizes="(max-width: 730px) 100vw, 730px" data-src="https://westsidetoday.com/wp-content/uploads/2019/11/CCFD-Firefighters-730x364.jpg" class="attachment-weart-grid size-weart-grid wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="730" height="364" src="https://westsidetoday.com/wp-content/uploads/2019/11/CCFD-Firefighters-730x364.jpg" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://westsidetoday.com/wp-content/uploads/2019/11/CCFD-Firefighters-730x364.jpg 730w, https://westsidetoday.com/wp-content/uploads/2019/11/CCFD-Firefighters-300x150.jpg 300w, https://westsidetoday.com/wp-content/uploads/2019/11/CCFD-Firefighters-768x383.jpg 768w, https://westsidetoday.com/wp-content/uploads/2019/11/CCFD-Firefighters-350x175.jpg 350w, https://westsidetoday.com/wp-content/uploads/2019/11/CCFD-Firefighters-360x180.jpg 360w, https://westsidetoday.com/wp-content/uploads/2019/11/CCFD-Firefighters-750x374.jpg 750w, https://westsidetoday.com/wp-content/uploads/2019/11/CCFD-Firefighters.jpg 802w" sizes="(max-width: 730px) 100vw, 730px" /></noscript><div class="ccfic"><span class="ccfic-text">CCFD's Shawn Allois (left) and Captain Michael Canchola (right). Photos: Courtesy</span></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://westsidetoday.com/culver-city/" rel="category tag">Culver City</a>, <a href="https://westsidetoday.com/featured/" rel="category tag">Featured</a>, <a href="https://westsidetoday.com/news/" rel="category tag">News</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://westsidetoday.com/2019/11/04/culver-city-firefighters-movember/" title="Culver City Firefighters Movember">
                Culver City Firefighters Movember              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">November 4, 2019</span>      <span class="author"><a href="https://westsidetoday.com/author/westsidetodaystaff/" title="Posts by Westside Today Staff" rel="author">Westside Today Staff</a></span>
          </p>

    <div class="left d-none">
      <a href="https://westsidetoday.com/2019/11/04/culver-city-firefighters-movember/" title="Culver City Firefighters Movember">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">November 4, 2019</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">By Keldine Hull Culver City firefighters will be growing mustaches throughout November in honor of Movember, a month-long campaign created...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 border-top post-130869 post type-post status-publish format-standard has-post-thumbnail hentry category-edify-tv category-featured category-news">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://westsidetoday.com/2019/11/01/getty-fire-forces-widespread-westside-evacuations-westside-today-news-show-november-1-2019/" title="Getty Fire Forces Widespread Westside Evacuations: Westside Today News Show November 1, 2019">
                              <img width="730" height="408"   alt="" data-srcset="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-01-at-10.06.17-AM-730x408.png 730w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-01-at-10.06.17-AM-300x168.png 300w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-01-at-10.06.17-AM-768x429.png 768w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-01-at-10.06.17-AM-1024x572.png 1024w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-01-at-10.06.17-AM-350x196.png 350w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-01-at-10.06.17-AM-1100x615.png 1100w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-01-at-10.06.17-AM-750x419.png 750w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-01-at-10.06.17-AM-1140x637.png 1140w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-01-at-10.06.17-AM.png 1592w" sizes="(max-width: 730px) 100vw, 730px" data-src="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-01-at-10.06.17-AM-730x408.png" class="attachment-weart-grid size-weart-grid wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="730" height="408" src="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-01-at-10.06.17-AM-730x408.png" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-01-at-10.06.17-AM-730x408.png 730w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-01-at-10.06.17-AM-300x168.png 300w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-01-at-10.06.17-AM-768x429.png 768w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-01-at-10.06.17-AM-1024x572.png 1024w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-01-at-10.06.17-AM-350x196.png 350w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-01-at-10.06.17-AM-1100x615.png 1100w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-01-at-10.06.17-AM-750x419.png 750w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-01-at-10.06.17-AM-1140x637.png 1140w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-01-at-10.06.17-AM.png 1592w" sizes="(max-width: 730px) 100vw, 730px" /></noscript><div class="ccfic"></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://westsidetoday.com/edify-tv/" rel="category tag">Edify Tv</a>, <a href="https://westsidetoday.com/featured/" rel="category tag">Featured</a>, <a href="https://westsidetoday.com/news/" rel="category tag">News</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://westsidetoday.com/2019/11/01/getty-fire-forces-widespread-westside-evacuations-westside-today-news-show-november-1-2019/" title="Getty Fire Forces Widespread Westside Evacuations: Westside Today News Show November 1, 2019">
                Getty Fire Forces Widespread Westside Evacuations: Westside Today News Show November 1, 2019              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">November 1, 2019</span>      <span class="author"><a href="https://westsidetoday.com/author/videointern/" title="Posts by Video" rel="author">Video</a></span>
          </p>

    <div class="left d-none">
      <a href="https://westsidetoday.com/2019/11/01/getty-fire-forces-widespread-westside-evacuations-westside-today-news-show-november-1-2019/" title="Getty Fire Forces Widespread Westside Evacuations: Westside Today News Show November 1, 2019">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">November 1, 2019</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">Westside Today News Show November 1, 2019 &#8211; special coverage of the #GettyFire, which as of Friday morning has burned...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 border-top post-130867 post type-post status-publish format-standard has-post-thumbnail hentry category-edify-tv category-featured category-news">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://westsidetoday.com/2019/10/31/edify-tv-marina-spooktacular-2019/" title="Edify TV: Marina Spooktacular 2019">
                              <img width="730" height="419"   alt="" data-srcset="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-31-at-3.23.52-PM-730x419.png 730w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-31-at-3.23.52-PM-300x172.png 300w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-31-at-3.23.52-PM-768x440.png 768w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-31-at-3.23.52-PM-1024x587.png 1024w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-31-at-3.23.52-PM-350x201.png 350w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-31-at-3.23.52-PM-1100x631.png 1100w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-31-at-3.23.52-PM-750x430.png 750w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-31-at-3.23.52-PM-1140x654.png 1140w" sizes="(max-width: 730px) 100vw, 730px" data-src="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-31-at-3.23.52-PM-730x419.png" class="attachment-weart-grid size-weart-grid wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="730" height="419" src="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-31-at-3.23.52-PM-730x419.png" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-31-at-3.23.52-PM-730x419.png 730w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-31-at-3.23.52-PM-300x172.png 300w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-31-at-3.23.52-PM-768x440.png 768w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-31-at-3.23.52-PM-1024x587.png 1024w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-31-at-3.23.52-PM-350x201.png 350w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-31-at-3.23.52-PM-1100x631.png 1100w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-31-at-3.23.52-PM-750x430.png 750w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-31-at-3.23.52-PM-1140x654.png 1140w" sizes="(max-width: 730px) 100vw, 730px" /></noscript><div class="ccfic"></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://westsidetoday.com/edify-tv/" rel="category tag">Edify Tv</a>, <a href="https://westsidetoday.com/featured/" rel="category tag">Featured</a>, <a href="https://westsidetoday.com/news/" rel="category tag">News</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://westsidetoday.com/2019/10/31/edify-tv-marina-spooktacular-2019/" title="Edify TV: Marina Spooktacular 2019">
                Edify TV: Marina Spooktacular 2019              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">October 31, 2019</span>      <span class="author"><a href="https://westsidetoday.com/author/videointern/" title="Posts by Video" rel="author">Video</a></span>
          </p>

    <div class="left d-none">
      <a href="https://westsidetoday.com/2019/10/31/edify-tv-marina-spooktacular-2019/" title="Edify TV: Marina Spooktacular 2019">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">October 31, 2019</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">Over the weekend kids braved the Marina del Spooktacular, a two-day festival put on by LA County offering scares for...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 border-top post-130858 post type-post status-publish format-standard has-post-thumbnail hentry category-edify-tv category-featured category-news">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://westsidetoday.com/2019/10/29/edify-tv-animals-evacuated-from-getty-fire/" title="Edify TV: Animals Evacuated From Getty Fire">
                              <img width="730" height="404"   alt="" data-srcset="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-11.49.55-AM-730x404.png 730w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-11.49.55-AM-300x166.png 300w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-11.49.55-AM-768x425.png 768w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-11.49.55-AM-350x194.png 350w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-11.49.55-AM-750x415.png 750w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-11.49.55-AM.png 794w" sizes="(max-width: 730px) 100vw, 730px" data-src="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-11.49.55-AM-730x404.png" class="attachment-weart-grid size-weart-grid wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="730" height="404" src="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-11.49.55-AM-730x404.png" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-11.49.55-AM-730x404.png 730w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-11.49.55-AM-300x166.png 300w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-11.49.55-AM-768x425.png 768w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-11.49.55-AM-350x194.png 350w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-11.49.55-AM-750x415.png 750w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-11.49.55-AM.png 794w" sizes="(max-width: 730px) 100vw, 730px" /></noscript><div class="ccfic"></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://westsidetoday.com/edify-tv/" rel="category tag">Edify Tv</a>, <a href="https://westsidetoday.com/featured/" rel="category tag">Featured</a>, <a href="https://westsidetoday.com/news/" rel="category tag">News</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://westsidetoday.com/2019/10/29/edify-tv-animals-evacuated-from-getty-fire/" title="Edify TV: Animals Evacuated From Getty Fire">
                Edify TV: Animals Evacuated From Getty Fire              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">October 29, 2019</span>      <span class="author"><a href="https://westsidetoday.com/author/videointern/" title="Posts by Video" rel="author">Video</a></span>
          </p>

    <div class="left d-none">
      <a href="https://westsidetoday.com/2019/10/29/edify-tv-animals-evacuated-from-getty-fire/" title="Edify TV: Animals Evacuated From Getty Fire">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">October 29, 2019</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">The West Los Angeles Animal Care Center is helping house and care for animals displaced by the Getty Fire. Learn...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 border-top post-130860 post type-post status-publish format-standard has-post-thumbnail hentry category-edify-tv category-featured category-news">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://westsidetoday.com/2019/10/28/edify-tv-westside-halloween-safety/" title="Edify TV: Westside Halloween Safety">
                              <img width="730" height="410"   alt="" data-srcset="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-12.24.10-PM-730x410.png 730w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-12.24.10-PM-300x169.png 300w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-12.24.10-PM-768x432.png 768w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-12.24.10-PM-350x197.png 350w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-12.24.10-PM-750x421.png 750w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-12.24.10-PM.png 799w" sizes="(max-width: 730px) 100vw, 730px" data-src="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-12.24.10-PM-730x410.png" class="attachment-weart-grid size-weart-grid wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="730" height="410" src="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-12.24.10-PM-730x410.png" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-12.24.10-PM-730x410.png 730w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-12.24.10-PM-300x169.png 300w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-12.24.10-PM-768x432.png 768w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-12.24.10-PM-350x197.png 350w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-12.24.10-PM-750x421.png 750w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-29-at-12.24.10-PM.png 799w" sizes="(max-width: 730px) 100vw, 730px" /></noscript><div class="ccfic"></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://westsidetoday.com/edify-tv/" rel="category tag">Edify Tv</a>, <a href="https://westsidetoday.com/featured/" rel="category tag">Featured</a>, <a href="https://westsidetoday.com/news/" rel="category tag">News</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://westsidetoday.com/2019/10/28/edify-tv-westside-halloween-safety/" title="Edify TV: Westside Halloween Safety">
                Edify TV: Westside Halloween Safety              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">October 28, 2019</span>      <span class="author"><a href="https://westsidetoday.com/author/videointern/" title="Posts by Video" rel="author">Video</a></span>
          </p>

    <div class="left d-none">
      <a href="https://westsidetoday.com/2019/10/28/edify-tv-westside-halloween-safety/" title="Edify TV: Westside Halloween Safety">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">October 28, 2019</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">Stay safe and have a happy Halloween! Make sure your kids&#8217; costumes have reflective tape or add glowsticks to make...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 border-top post-130862 post type-post status-publish format-standard has-post-thumbnail hentry category-edify-tv category-featured category-news">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://westsidetoday.com/2019/10/28/westside-today-news-show-october-28-2019-getty-fire-coverage/" title="Westside Today News Show October 28, 2019: Getty Fire Coverage">
                              <img width="730" height="410"   alt="" data-srcset="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-10.39.19-AM-730x410.png 730w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-10.39.19-AM-300x168.png 300w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-10.39.19-AM-768x431.png 768w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-10.39.19-AM-1024x575.png 1024w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-10.39.19-AM-350x197.png 350w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-10.39.19-AM-1100x618.png 1100w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-10.39.19-AM-750x421.png 750w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-10.39.19-AM-1140x640.png 1140w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-10.39.19-AM.png 1592w" sizes="(max-width: 730px) 100vw, 730px" data-src="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-10.39.19-AM-730x410.png" class="attachment-weart-grid size-weart-grid wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="730" height="410" src="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-10.39.19-AM-730x410.png" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-10.39.19-AM-730x410.png 730w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-10.39.19-AM-300x168.png 300w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-10.39.19-AM-768x431.png 768w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-10.39.19-AM-1024x575.png 1024w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-10.39.19-AM-350x197.png 350w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-10.39.19-AM-1100x618.png 1100w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-10.39.19-AM-750x421.png 750w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-10.39.19-AM-1140x640.png 1140w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-10.39.19-AM.png 1592w" sizes="(max-width: 730px) 100vw, 730px" /></noscript><div class="ccfic"></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://westsidetoday.com/edify-tv/" rel="category tag">Edify Tv</a>, <a href="https://westsidetoday.com/featured/" rel="category tag">Featured</a>, <a href="https://westsidetoday.com/news/" rel="category tag">News</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://westsidetoday.com/2019/10/28/westside-today-news-show-october-28-2019-getty-fire-coverage/" title="Westside Today News Show October 28, 2019: Getty Fire Coverage">
                Westside Today News Show October 28, 2019: Getty Fire Coverage              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">October 28, 2019</span>      <span class="author"><a href="https://westsidetoday.com/author/videointern/" title="Posts by Video" rel="author">Video</a></span>
          </p>

    <div class="left d-none">
      <a href="https://westsidetoday.com/2019/10/28/westside-today-news-show-october-28-2019-getty-fire-coverage/" title="Westside Today News Show October 28, 2019: Getty Fire Coverage">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">October 28, 2019</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">Westside Today News Show October 28, 2019 &#8211; special coverage of the #GettyFire that has forced mandatory evacuation orders for...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 border-top post-130855 post type-post status-publish format-standard has-post-thumbnail hentry category-culver-city category-featured category-news category-real-estate tag-culver-city tag-motor-avenue tag-palms tag-westside-today">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://westsidetoday.com/2019/10/27/another-mixed-used-development-slated-for-palms/" title="Another Mixed-Used Development Slated for Palms">
                              <img width="730" height="483"   alt="" data-srcset="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-12.17.00-AM-730x483.png 730w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-12.17.00-AM-300x199.png 300w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-12.17.00-AM-768x509.png 768w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-12.17.00-AM-350x232.png 350w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-12.17.00-AM-750x497.png 750w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-12.17.00-AM.png 906w" sizes="(max-width: 730px) 100vw, 730px" data-src="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-12.17.00-AM-730x483.png" class="attachment-weart-grid size-weart-grid wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="730" height="483" src="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-12.17.00-AM-730x483.png" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-12.17.00-AM-730x483.png 730w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-12.17.00-AM-300x199.png 300w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-12.17.00-AM-768x509.png 768w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-12.17.00-AM-350x232.png 350w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-12.17.00-AM-750x497.png 750w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-28-at-12.17.00-AM.png 906w" sizes="(max-width: 730px) 100vw, 730px" /></noscript><div class="ccfic"><span class="ccfic-text">3451 S. Motor Avenue. Photo: Google. </span></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://westsidetoday.com/culver-city/" rel="category tag">Culver City</a>, <a href="https://westsidetoday.com/featured/" rel="category tag">Featured</a>, <a href="https://westsidetoday.com/news/" rel="category tag">News</a>, <a href="https://westsidetoday.com/real-estate/" rel="category tag">Real Estate</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://westsidetoday.com/2019/10/27/another-mixed-used-development-slated-for-palms/" title="Another Mixed-Used Development Slated for Palms">
                Another Mixed-Used Development Slated for Palms              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">October 27, 2019</span>      <span class="author"><a href="https://westsidetoday.com/author/samcatanzaro/" title="Posts by Sam Catanzaro" rel="author">Sam Catanzaro</a></span>
          </p>

    <div class="left d-none">
      <a href="https://westsidetoday.com/2019/10/27/another-mixed-used-development-slated-for-palms/" title="Another Mixed-Used Development Slated for Palms">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">October 27, 2019</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">Developer wants to build six-story housing project on Motor Avenue By Sam Catanzaro A developer wants to build a six-story,...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 border-top post-130851 post type-post status-publish format-standard has-post-thumbnail hentry category-culver-city category-featured category-news">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://westsidetoday.com/2019/10/25/cleaning-up-ballona-creek/" title="Cleaning up Ballona Creek">
                              <img width="730" height="391"   alt="" data-srcset="https://westsidetoday.com/wp-content/uploads/2019/10/1.BalonnaCreek-730x391.jpg 730w, https://westsidetoday.com/wp-content/uploads/2019/10/1.BalonnaCreek-300x161.jpg 300w, https://westsidetoday.com/wp-content/uploads/2019/10/1.BalonnaCreek-768x411.jpg 768w, https://westsidetoday.com/wp-content/uploads/2019/10/1.BalonnaCreek-1024x548.jpg 1024w, https://westsidetoday.com/wp-content/uploads/2019/10/1.BalonnaCreek-350x187.jpg 350w, https://westsidetoday.com/wp-content/uploads/2019/10/1.BalonnaCreek-1100x589.jpg 1100w, https://westsidetoday.com/wp-content/uploads/2019/10/1.BalonnaCreek-750x401.jpg 750w, https://westsidetoday.com/wp-content/uploads/2019/10/1.BalonnaCreek.jpg 1121w" sizes="(max-width: 730px) 100vw, 730px" data-src="https://westsidetoday.com/wp-content/uploads/2019/10/1.BalonnaCreek-730x391.jpg" class="attachment-weart-grid size-weart-grid wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="730" height="391" src="https://westsidetoday.com/wp-content/uploads/2019/10/1.BalonnaCreek-730x391.jpg" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://westsidetoday.com/wp-content/uploads/2019/10/1.BalonnaCreek-730x391.jpg 730w, https://westsidetoday.com/wp-content/uploads/2019/10/1.BalonnaCreek-300x161.jpg 300w, https://westsidetoday.com/wp-content/uploads/2019/10/1.BalonnaCreek-768x411.jpg 768w, https://westsidetoday.com/wp-content/uploads/2019/10/1.BalonnaCreek-1024x548.jpg 1024w, https://westsidetoday.com/wp-content/uploads/2019/10/1.BalonnaCreek-350x187.jpg 350w, https://westsidetoday.com/wp-content/uploads/2019/10/1.BalonnaCreek-1100x589.jpg 1100w, https://westsidetoday.com/wp-content/uploads/2019/10/1.BalonnaCreek-750x401.jpg 750w, https://westsidetoday.com/wp-content/uploads/2019/10/1.BalonnaCreek.jpg 1121w" sizes="(max-width: 730px) 100vw, 730px" /></noscript><div class="ccfic"><span class="ccfic-text">Photo: Ballona Creek Renaissance.</span></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://westsidetoday.com/culver-city/" rel="category tag">Culver City</a>, <a href="https://westsidetoday.com/featured/" rel="category tag">Featured</a>, <a href="https://westsidetoday.com/news/" rel="category tag">News</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://westsidetoday.com/2019/10/25/cleaning-up-ballona-creek/" title="Cleaning up Ballona Creek">
                Cleaning up Ballona Creek              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">October 25, 2019</span>      <span class="author"><a href="https://westsidetoday.com/author/westsidetodaystaff/" title="Posts by Westside Today Staff" rel="author">Westside Today Staff</a></span>
          </p>

    <div class="left d-none">
      <a href="https://westsidetoday.com/2019/10/25/cleaning-up-ballona-creek/" title="Cleaning up Ballona Creek">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">October 25, 2019</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">LA County and The Ocean Cleanup to announce new innovative tech to clean Ballona Creek By Chad Winthrop Chair of...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 border-top post-130849 post type-post status-publish format-standard has-post-thumbnail hentry category-edify-tv category-featured category-news">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://westsidetoday.com/2019/10/25/londons-st-johns-restaurant-coming-to-culver-city-trick-or-treat-at-westfield-fox-hill-westside-today-show-october-25-2019/" title="London&#8217;s St. John&#8217;s Restaurant coming to Culver City, Trick or treat at Westfield Fox Hill: Westside Today Show October 25, 2019">
                              <img width="730" height="408"   alt="" data-srcset="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-25-at-2.36.38-PM-730x408.png 730w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-25-at-2.36.38-PM-300x168.png 300w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-25-at-2.36.38-PM-768x430.png 768w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-25-at-2.36.38-PM-1024x573.png 1024w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-25-at-2.36.38-PM-350x196.png 350w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-25-at-2.36.38-PM-1100x615.png 1100w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-25-at-2.36.38-PM-750x420.png 750w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-25-at-2.36.38-PM-1140x638.png 1140w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-25-at-2.36.38-PM.png 1598w" sizes="(max-width: 730px) 100vw, 730px" data-src="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-25-at-2.36.38-PM-730x408.png" class="attachment-weart-grid size-weart-grid wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="730" height="408" src="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-25-at-2.36.38-PM-730x408.png" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-25-at-2.36.38-PM-730x408.png 730w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-25-at-2.36.38-PM-300x168.png 300w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-25-at-2.36.38-PM-768x430.png 768w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-25-at-2.36.38-PM-1024x573.png 1024w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-25-at-2.36.38-PM-350x196.png 350w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-25-at-2.36.38-PM-1100x615.png 1100w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-25-at-2.36.38-PM-750x420.png 750w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-25-at-2.36.38-PM-1140x638.png 1140w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-25-at-2.36.38-PM.png 1598w" sizes="(max-width: 730px) 100vw, 730px" /></noscript><div class="ccfic"></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://westsidetoday.com/edify-tv/" rel="category tag">Edify Tv</a>, <a href="https://westsidetoday.com/featured/" rel="category tag">Featured</a>, <a href="https://westsidetoday.com/news/" rel="category tag">News</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://westsidetoday.com/2019/10/25/londons-st-johns-restaurant-coming-to-culver-city-trick-or-treat-at-westfield-fox-hill-westside-today-show-october-25-2019/" title="London&#8217;s St. John&#8217;s Restaurant coming to Culver City, Trick or treat at Westfield Fox Hill: Westside Today Show October 25, 2019">
                London&#8217;s St. John&#8217;s Restaurant coming to Culver City, Trick or treat at Westfield Fox Hill: Westside Today Show October 25, 2019              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">October 25, 2019</span>      <span class="author"><a href="https://westsidetoday.com/author/videointern/" title="Posts by Video" rel="author">Video</a></span>
          </p>

    <div class="left d-none">
      <a href="https://westsidetoday.com/2019/10/25/londons-st-johns-restaurant-coming-to-culver-city-trick-or-treat-at-westfield-fox-hill-westside-today-show-october-25-2019/" title="London&#8217;s St. John&#8217;s Restaurant coming to Culver City, Trick or treat at Westfield Fox Hill: Westside Today Show October 25, 2019">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">October 25, 2019</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">Westside Today Show October 25, 2019 &#8211; all your local news and events in under 5 minutes.* London&#8217;s St. John&#8217;s...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 border-top post-130847 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-news category-pacific-palisades">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://westsidetoday.com/2019/10/23/palisades-fire-remains-30-contained/" title="Palisades Fire Remains 30% Contained">
                              <img width="730" height="404"   alt="" data-srcset="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-22-at-8.52.48-AM-1-730x404.png 730w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-22-at-8.52.48-AM-1-300x166.png 300w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-22-at-8.52.48-AM-1-768x425.png 768w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-22-at-8.52.48-AM-1-350x194.png 350w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-22-at-8.52.48-AM-1-750x415.png 750w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-22-at-8.52.48-AM-1.png 900w" sizes="(max-width: 730px) 100vw, 730px" data-src="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-22-at-8.52.48-AM-1-730x404.png" class="attachment-weart-grid size-weart-grid wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="730" height="404" src="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-22-at-8.52.48-AM-1-730x404.png" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-22-at-8.52.48-AM-1-730x404.png 730w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-22-at-8.52.48-AM-1-300x166.png 300w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-22-at-8.52.48-AM-1-768x425.png 768w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-22-at-8.52.48-AM-1-350x194.png 350w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-22-at-8.52.48-AM-1-750x415.png 750w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-22-at-8.52.48-AM-1.png 900w" sizes="(max-width: 730px) 100vw, 730px" /></noscript><div class="ccfic"><span class="ccfic-text">The Palisades Fire burns Monday. Photo: Los Angeles Country Fire Department Air Ops.</span></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://westsidetoday.com/featured/" rel="category tag">Featured</a>, <a href="https://westsidetoday.com/news/" rel="category tag">News</a>, <a href="https://westsidetoday.com/pacific-palisades/" rel="category tag">Pacific Palisades</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://westsidetoday.com/2019/10/23/palisades-fire-remains-30-contained/" title="Palisades Fire Remains 30% Contained">
                Palisades Fire Remains 30% Contained              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">October 23, 2019</span>      <span class="author"><a href="https://westsidetoday.com/author/samcatanzaro/" title="Posts by Sam Catanzaro" rel="author">Sam Catanzaro</a></span>
          </p>

    <div class="left d-none">
      <a href="https://westsidetoday.com/2019/10/23/palisades-fire-remains-30-contained/" title="Palisades Fire Remains 30% Contained">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">October 23, 2019</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">2 firefighters hit by falling rocks as Palisades Fire Remains at 45 acres By Sam Catanzaro As of 9 a.m....</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 border-top post-130845 post type-post status-publish format-standard has-post-thumbnail hentry category-culver-city category-featured category-health-fit category-news tag-culver-city tag-culver-city-news tag-measles tag-news-2 tag-palms tag-starbucks tag-westside">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://westsidetoday.com/2019/10/23/individual-with-measles-visited-palms-starbucks/" title="Individual With Measles Visited Palms Starbucks">
                              <img width="730" height="447"   alt="" data-srcset="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-23-at-1.58.07-PM-730x447.png 730w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-23-at-1.58.07-PM-300x184.png 300w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-23-at-1.58.07-PM-768x471.png 768w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-23-at-1.58.07-PM-350x215.png 350w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-23-at-1.58.07-PM-750x460.png 750w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-23-at-1.58.07-PM.png 979w" sizes="(max-width: 730px) 100vw, 730px" data-src="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-23-at-1.58.07-PM-730x447.png" class="attachment-weart-grid size-weart-grid wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="730" height="447" src="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-23-at-1.58.07-PM-730x447.png" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-23-at-1.58.07-PM-730x447.png 730w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-23-at-1.58.07-PM-300x184.png 300w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-23-at-1.58.07-PM-768x471.png 768w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-23-at-1.58.07-PM-350x215.png 350w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-23-at-1.58.07-PM-750x460.png 750w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-23-at-1.58.07-PM.png 979w" sizes="(max-width: 730px) 100vw, 730px" /></noscript><div class="ccfic"><span class="ccfic-text">A Starbucks in a strip mall on Sepulveda where a person with measles visited October 16. Photo: Google. </span></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://westsidetoday.com/culver-city/" rel="category tag">Culver City</a>, <a href="https://westsidetoday.com/featured/" rel="category tag">Featured</a>, <a href="https://westsidetoday.com/lifestyle/health-fit/" rel="category tag">Health + Fitness</a>, <a href="https://westsidetoday.com/news/" rel="category tag">News</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://westsidetoday.com/2019/10/23/individual-with-measles-visited-palms-starbucks/" title="Individual With Measles Visited Palms Starbucks">
                Individual With Measles Visited Palms Starbucks              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">October 23, 2019</span>      <span class="author"><a href="https://westsidetoday.com/author/samcatanzaro/" title="Posts by Sam Catanzaro" rel="author">Sam Catanzaro</a></span>
          </p>

    <div class="left d-none">
      <a href="https://westsidetoday.com/2019/10/23/individual-with-measles-visited-palms-starbucks/" title="Individual With Measles Visited Palms Starbucks">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">October 23, 2019</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">Potential exposure October 16 By Sam Catanzaro The Los Angeles County Department of Public Health (Public Health) is investigating an...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 border-top post-130842 post type-post status-publish format-standard has-post-thumbnail hentry category-edify-tv category-featured category-news">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://westsidetoday.com/2019/10/22/culver-city-council-bans-sale-of-flavored-tobacco-and-vapes-food-truck-competition-comes-to-culver-city-westside-today-news-show-october-21-2019/" title="Culver City Council bans sale of flavored tobacco and vapes, Food truck competition comes to Culver City: Westside Today News Show October 21, 2019">
                              <img width="730" height="406"   alt="" data-srcset="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-21-at-2.30.13-PM-730x406.png 730w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-21-at-2.30.13-PM-300x167.png 300w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-21-at-2.30.13-PM-768x427.png 768w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-21-at-2.30.13-PM-350x195.png 350w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-21-at-2.30.13-PM-750x417.png 750w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-21-at-2.30.13-PM.png 798w" sizes="(max-width: 730px) 100vw, 730px" data-src="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-21-at-2.30.13-PM-730x406.png" class="attachment-weart-grid size-weart-grid wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="730" height="406" src="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-21-at-2.30.13-PM-730x406.png" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-21-at-2.30.13-PM-730x406.png 730w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-21-at-2.30.13-PM-300x167.png 300w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-21-at-2.30.13-PM-768x427.png 768w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-21-at-2.30.13-PM-350x195.png 350w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-21-at-2.30.13-PM-750x417.png 750w, https://westsidetoday.com/wp-content/uploads/2019/10/Screen-Shot-2019-10-21-at-2.30.13-PM.png 798w" sizes="(max-width: 730px) 100vw, 730px" /></noscript><div class="ccfic"></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://westsidetoday.com/edify-tv/" rel="category tag">Edify Tv</a>, <a href="https://westsidetoday.com/featured/" rel="category tag">Featured</a>, <a href="https://westsidetoday.com/news/" rel="category tag">News</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://westsidetoday.com/2019/10/22/culver-city-council-bans-sale-of-flavored-tobacco-and-vapes-food-truck-competition-comes-to-culver-city-westside-today-news-show-october-21-2019/" title="Culver City Council bans sale of flavored tobacco and vapes, Food truck competition comes to Culver City: Westside Today News Show October 21, 2019">
                Culver City Council bans sale of flavored tobacco and vapes, Food truck competition comes to Culver City: Westside Today News Show October 21, 2019              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">October 22, 2019</span>      <span class="author"><a href="https://westsidetoday.com/author/videointern/" title="Posts by Video" rel="author">Video</a></span>
          </p>

    <div class="left d-none">
      <a href="https://westsidetoday.com/2019/10/22/culver-city-council-bans-sale-of-flavored-tobacco-and-vapes-food-truck-competition-comes-to-culver-city-westside-today-news-show-october-21-2019/" title="Culver City Council bans sale of flavored tobacco and vapes, Food truck competition comes to Culver City: Westside Today News Show October 21, 2019">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">October 22, 2019</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">Westside Today News Show October 21, 2019 &#8211; all your local news and happenings in under 5 minutes!* Culver City...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>

  <!-- end -->

<!-- comment -->
  <div id="weart-comments" class="my-5">
        <div class="meta-title text-center f-title border-bottomm  pb-2 mb-3 border-bottom h6">
      <span class="c-1">Comments</span>
      <hr class="brd-black brd-bold my-1">
    </div>
  
<!-- comment form -->
      <div class="c-meta l-meta mb-5 f-text">
      	<div id="respond" class="comment-respond">
		<div class="mb-2 mt-5"><span class="f-title h4 c-black">Leave a Reply<span class="f-title small pl-2"><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/#respond" style="display:none;">Cancel reply</a></span></span></div>			<form action="https://westsidetoday.com/wp-comments-post.php?wpe-comment-post=westsidetoday" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><div class="form-group"><textarea name="comment" class="form-control rounded-0 w-category f-meta" id="comment" rows="5" aria-required="true"></textarea></div><div class="row"><div class="author col form-group"><input id="author" class="form-control rounded-0 w-category f-meta" placeholder="Name" name="author" type="text" value="" size="30" aria-required='true' /></div>
<div class="email col form-group"><input id="email" class="form-control rounded-0 w-category f-meta" placeholder="Email" name="email" type="text" value="" size="30" aria-required='true' /></div></div>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit btn btn-dark btn-sm w-category f-meta text-uppercase px-3 py-2 rounded-0" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='130882' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>			</form>
			</div><!-- #respond -->
	    </div>
  <!-- end -->
  </div>
<!-- end -->          </div>
        </div>
        <!-- sidebar -->
            <div class="sidebar col-lg-4 c-text l-text border-left">
    <div class="sidebar-inner " id="sidebar-inner">
      <div id="search-3" class="widget_search box mb-5"><form role="search" method="get" class="search-form d-block" action="https://westsidetoday.com/">
  <div class="input-group  input-group-sm">
    <input type="search" class="form-control search-field rounded-0 f-main border" placeholder="Search for..." aria-label="Search for..." name="s">
    <span class="input-group-btn">
      <button class="btn bg-1 c-white search-submit rounded-0" type="submit"><i class="fas fa-search"></i></button>
    </span>
  </div>
</form>
</div><div id="custom_html-5" class="widget_text widget_custom_html box mb-5"><h3 class="sidebar-title f-meta c-1"><span class="title">NEWSLETTER</span></h3><div class="textwidget custom-html-widget"><div data-form-id="130647" id="ctct-form-wrapper-0" class="ctct-form-wrapper"><form class="ctct-form ctct-form-130647 no-recaptcha" id="ctct-form-3293594419" data-doajax="off" style="" action="" method="post"><span class="ctct-form-description" ><p>Join our newsletter! Receive the latest news, events, and opinion in the Westside and surrounding areas.</p>
</span><p class="ctct-form-field ctct-form-field-email ctct-form-field-required"><span class="ctct-label-top"><label for="email___3c59495a3edf2d27cd20fc1987544522">Email (required) <abbr title="required">*</abbr></label></span><input required type="email" name="email___3c59495a3edf2d27cd20fc1987544522" id="email___3c59495a3edf2d27cd20fc1987544522"  value=""  placeholder="" class="ctct-email ctct-label-top" /></p><div class="ctct-optin-hide" style="display:none;"><p class="ctct-form-field ctct-form-field-checkbox"><span class="ctct-input-container"><input type="checkbox" checked name="ctct-opt-in" id="ctct-opt-in" class="ctct-checkbox ctct-opt-in" value="1544251899" /><label for="ctct-opt-in"> Example: Yes, I would like to receive emails from WestsideToday. (You can unsubscribe anytime)</label></span></p></div><!--.ctct-optin-hide --><div id="ctct_usage"><label for="ctct_usage_field">Constant Contact Use.</label><input type="text" value="" name="ctct_usage_field" id="ctct_usage_field" /></div><p class="ctct-form-field ctct-form-field-hidden"><input  type="hidden" name="ctct-id" id="ctct-id"  value="130647"  placeholder="" class="ctct-hidden ctct-label-" /><p class="ctct-form-field ctct-form-field-hidden"><input  type="hidden" name="ctct-verify" id="ctct-verify"  value="nBvKRewkdHQoDyN7qokO1dXbB"  placeholder="" class="ctct-hidden ctct-label-" /><input type="hidden" name="ctct_time" value="1573037243" /><p class="ctct-form-field ctct-form-field-submit"><input  type="submit" name="ctct-submitted" id="ctct-submitted"  value="SIGN UP"  placeholder="" class="ctct-submit ctct-label-" /></p><input type="hidden" id="ctct_form" name="ctct_form" value="3ecb254896" /><input type="hidden" name="_wp_http_referer" value="/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/" /><div class="ctct-disclosure"><hr><sub>By submitting this form, you are consenting to receive marketing emails from: Santa Monica Mirror, 2116 Wilshire Blvd., Santa Monica, CA, 90403, http://www.smmirror.com. You can revoke your consent to receive emails at any time by using the SafeUnsubscribe&reg; link, found at the bottom of every email. <a href="https://www.constantcontact.com/legal/service-provider" target="_blank" rel="noopener noreferrer">Emails are serviced by Constant Contact</a></sub></div></form><script type="text/javascript">var ajaxurl = "https://westsidetoday.com/wp-admin/admin-ajax.php";</script></div></div></div><div id="custom_html-3" class="widget_text widget_custom_html box mb-5"><div class="textwidget custom-html-widget"><script src='https://www.googletagservices.com/tag/js/gpt.js'>
  googletag.pubads().definePassback('/21621973880/westsidetoday_sidebarhalfpage', [300, 600]).display();
</script></div></div><div id="custom_html-6" class="widget_text widget_custom_html box mb-5"><div class="textwidget custom-html-widget"><script src='https://www.googletagservices.com/tag/js/gpt.js'>
  googletag.pubads().definePassback('/21621973880/westsidetoday_articleinline', [300, 250]).display();
</script></div></div><div id="custom_html-8" class="widget_text widget_custom_html box mb-5"><h3 class="sidebar-title f-meta c-1"><span class="title">RECENT POSTS</span></h3><div class="textwidget custom-html-widget"></div></div><div id="epic_module_block_1-2" class="widget_epic_module_block_1 box mb-5"><div  class="jeg_postblock_1 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_1o3 epic_module_130882_0_5dc3153b359ec  normal " data-unique="epic_module_130882_0_5dc3153b359ec">
                
                <div class="jeg_block_container jeg_load_more_flag">
                
                <div class="jeg_posts">
                <article class="jeg_post jeg_pl_lg_1 post-130889 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-health-fit category-lifestyle category-news">
                    <div class="jeg_thumb">
                
                <a href="https://westsidetoday.com/2019/11/05/lily-the-pink-helping-women-look-their-best/"><div class="thumbnail-container animate-lazy  size-500 "><img width="360" height="180" src="https://westsidetoday.com/wp-content/plugins/epic-news-element/assets/img/jeg-empty.png" class="attachment-epic-360x180 size-epic-360x180 lazyload wp-post-image" alt="Lily the Pink – Helping Women Look Their Best" data-src="https://westsidetoday.com/wp-content/uploads/2019/11/Lily-Pink-360x180.png" data-sizes="auto" data-srcset="https://westsidetoday.com/wp-content/uploads/2019/11/Lily-Pink-360x180.png 360w, https://westsidetoday.com/wp-content/uploads/2019/11/Lily-Pink-750x375.png 750w" data-expand="700" /><div class="ccfic"><span class="ccfic-text">The area of Washington Place, west of Frances Avenue, where a fatal hit and run occurred over the weekend. Photo: Google. </span></div></div></a>
                <div class="jeg_post_category">
                    <span><a href="https://westsidetoday.com/featured/" class="category-featured">Featured</a></span>
                </div>
            </div>
            <div class="jeg_postblock_content">
                <h3 property="headline" class="jeg_post_title">
                    <a href="https://westsidetoday.com/2019/11/05/lily-the-pink-helping-women-look-their-best/">Lily the Pink – Helping Women Look Their Best</a>
                </h3>
                <div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://westsidetoday.com/author/westsidetodaystaff/">Westside Today Staff</a></div><div class="jeg_meta_date"><a href="https://westsidetoday.com/2019/11/05/lily-the-pink-helping-women-look-their-best/"><i class="fa fa-clock-o"></i> November 5, 2019</a></div><div class="jeg_meta_comment"><a href="https://westsidetoday.com/2019/11/05/lily-the-pink-helping-women-look-their-best/#respond" ><i class="fa fa-comment-o"></i> 0</a></div></div>
                <div class="jeg_post_excerpt">
                    <p>Sandy Allbright’s permanent makeup studio in Brentwood&nbsp; By Staff Writer For women who want to look their best all the...</p>
                    <a href="https://westsidetoday.com/2019/11/05/lily-the-pink-helping-women-look-their-best/" class="jeg_readmore">Read more</a>
                </div>
            </div>
                </article>
                <div class="jeg_postsmall">
                    <article class="jeg_post jeg_pl_sm post-130882 post type-post status-publish format-standard has-post-thumbnail hentry category-crime-courts category-culver-city category-featured category-news tag-ccfd tag-ccpd tag-culver-city tag-culver-city-fire-department tag-culver-city-news tag-culver-city-police-department tag-hit-and-run">
                <div class="jeg_thumb">
                    
                    <a href="https://westsidetoday.com/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/">
                        <div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://westsidetoday.com/wp-content/plugins/epic-news-element/assets/img/jeg-empty.png" class="attachment-epic-120x86 size-epic-120x86 lazyload wp-post-image" alt="Fatal Hit and Run Occurs in Culver City" data-src="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM-120x86.png" data-sizes="auto" data-srcset="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM-120x86.png 120w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM-350x250.png 350w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM-750x536.png 750w" data-expand="700" /><div class="ccfic"><span class="ccfic-text">The area of Washington Place, west of Frances Avenue, where a fatal hit and run occurred over the weekend. Photo: Google. </span></div></div>
                    </a>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://westsidetoday.com/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/">Fatal Hit and Run Occurs in Culver City</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://westsidetoday.com/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/" ><i class="fa fa-clock-o"></i> November 5, 2019</a></div></div>
                </div>
            </article><article class="jeg_post jeg_pl_sm post-130886 post type-post status-publish format-standard has-post-thumbnail hentry category-edify-tv category-featured category-news">
                <div class="jeg_thumb">
                    
                    <a href="https://westsidetoday.com/2019/11/05/edify-tv-dog-o-ween/">
                        <div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://westsidetoday.com/wp-content/plugins/epic-news-element/assets/img/jeg-empty.png" class="attachment-epic-120x86 size-epic-120x86 lazyload wp-post-image" alt="Edify TV: Dog-O-Ween" data-src="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-3.08.50-PM-120x86.png" data-sizes="auto" data-srcset="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-3.08.50-PM-120x86.png 120w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-3.08.50-PM-350x250.png 350w" data-expand="700" /><div class="ccfic"><span class="ccfic-text">The area of Washington Place, west of Frances Avenue, where a fatal hit and run occurred over the weekend. Photo: Google. </span></div></div>
                    </a>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://westsidetoday.com/2019/11/05/edify-tv-dog-o-ween/">Edify TV: Dog-O-Ween</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://westsidetoday.com/2019/11/05/edify-tv-dog-o-ween/" ><i class="fa fa-clock-o"></i> November 5, 2019</a></div></div>
                </div>
            </article><article class="jeg_post jeg_pl_sm post-130880 post type-post status-publish format-standard has-post-thumbnail hentry category-edify-tv category-featured category-news">
                <div class="jeg_thumb">
                    
                    <a href="https://westsidetoday.com/2019/11/04/new-hyatt-hotel-is-beginning-construction-at-culver-city-ivy-station-helms-bakery-district-fashion-sample-sale-westside-today-news-show-november-4-2019/">
                        <div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://westsidetoday.com/wp-content/plugins/epic-news-element/assets/img/jeg-empty.png" class="attachment-epic-120x86 size-epic-120x86 lazyload wp-post-image" alt="New Hyatt hotel is beginning construction at Culver City Ivy Station, Helms Bakery district fashion sample sale: Westside Today News Show November 4, 2019" data-src="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-04-at-2.19.52-PM-120x86.png" data-sizes="auto" data-srcset="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-04-at-2.19.52-PM-120x86.png 120w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-04-at-2.19.52-PM-350x250.png 350w" data-expand="700" /><div class="ccfic"><span class="ccfic-text">The area of Washington Place, west of Frances Avenue, where a fatal hit and run occurred over the weekend. Photo: Google. </span></div></div>
                    </a>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://westsidetoday.com/2019/11/04/new-hyatt-hotel-is-beginning-construction-at-culver-city-ivy-station-helms-bakery-district-fashion-sample-sale-westside-today-news-show-november-4-2019/">New Hyatt hotel is beginning construction at Culver City Ivy Station, Helms Bakery district fashion sample sale: Westside Today News Show November 4, 2019</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://westsidetoday.com/2019/11/04/new-hyatt-hotel-is-beginning-construction-at-culver-city-ivy-station-helms-bakery-district-fashion-sample-sale-westside-today-news-show-november-4-2019/" ><i class="fa fa-clock-o"></i> November 4, 2019</a></div></div>
                </div>
            </article><article class="jeg_post jeg_pl_sm post-130874 post type-post status-publish format-standard has-post-thumbnail hentry category-culver-city category-featured category-news">
                <div class="jeg_thumb">
                    
                    <a href="https://westsidetoday.com/2019/11/04/culver-city-firefighters-movember/">
                        <div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://westsidetoday.com/wp-content/plugins/epic-news-element/assets/img/jeg-empty.png" class="attachment-epic-120x86 size-epic-120x86 lazyload wp-post-image" alt="Culver City Firefighters Movember" data-src="https://westsidetoday.com/wp-content/uploads/2019/11/CCFD-Firefighters-120x86.jpg" data-sizes="auto" data-srcset="https://westsidetoday.com/wp-content/uploads/2019/11/CCFD-Firefighters-120x86.jpg 120w, https://westsidetoday.com/wp-content/uploads/2019/11/CCFD-Firefighters-350x250.jpg 350w" data-expand="700" /><div class="ccfic"><span class="ccfic-text">The area of Washington Place, west of Frances Avenue, where a fatal hit and run occurred over the weekend. Photo: Google. </span></div></div>
                    </a>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://westsidetoday.com/2019/11/04/culver-city-firefighters-movember/">Culver City Firefighters Movember</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://westsidetoday.com/2019/11/04/culver-city-firefighters-movember/" ><i class="fa fa-clock-o"></i> November 4, 2019</a></div></div>
                </div>
            </article>
                </div>
            </div>
                <div class='module-overlay'>
                <div class='preloader_type preloader_dot'>
                    <div class="module-preloader jeg_preloader dot">
                        <span></span><span></span><span></span>
                    </div>
                    <div class="module-preloader jeg_preloader circle">
                        <div class="epic_preloader_circle_outer">
                            <div class="epic_preloader_circle_inner"></div>
                        </div>
                    </div>
                    <div class="module-preloader jeg_preloader square">
                        <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                    </div>
                </div>
            </div>
            </div>
            <div class="jeg_block_navigation">
                <div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div>
                
                
            </div>
                
                <script>var epic_module_130882_0_5dc3153b359ec = {"header_icon":"","first_title":"","second_title":"","url":"","header_type":"heading_6","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","number_post":"5","post_offset":"0","unique_content":"disable","include_post":"","exclude_post":"","include_category":"","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","excerpt_length":"20","excerpt_ellipsis":"...","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":"5","pagination_scroll_limit":"0","boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"normal","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_1o3","class":"epic_block_1"};</script>
            </div></div><div id="custom_html-9" class="widget_text widget_custom_html box mb-5"><h3 class="sidebar-title f-meta c-1"><span class="title">POPULAR</span></h3><div class="textwidget custom-html-widget"></div></div><div id="epic_module_block_13-2" class="widget_epic_module_block_13 box mb-5"><div  class="jeg_postblock_13 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_1o3 epic_module_130882_1_5dc3153b3894f  normal " data-unique="epic_module_130882_1_5dc3153b3894f">
                
                <div class="jeg_block_container">
                
                <article class="jeg_post jeg_pl_lg_1 post-130889 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-health-fit category-lifestyle category-news">
                <div class="jeg_thumb">
                
                <a href="https://westsidetoday.com/2019/11/05/lily-the-pink-helping-women-look-their-best/"><div class="thumbnail-container animate-lazy  size-715 "><img width="350" height="250" src="https://westsidetoday.com/wp-content/plugins/epic-news-element/assets/img/jeg-empty.png" class="attachment-epic-350x250 size-epic-350x250 lazyload wp-post-image" alt="Lily the Pink – Helping Women Look Their Best" data-src="https://westsidetoday.com/wp-content/uploads/2019/11/Lily-Pink-350x250.png" data-sizes="auto" data-srcset="https://westsidetoday.com/wp-content/uploads/2019/11/Lily-Pink-350x250.png 350w, https://westsidetoday.com/wp-content/uploads/2019/11/Lily-Pink-120x86.png 120w, https://westsidetoday.com/wp-content/uploads/2019/11/Lily-Pink-750x536.png 750w" data-expand="700" /><div class="ccfic"><span class="ccfic-text">The area of Washington Place, west of Frances Avenue, where a fatal hit and run occurred over the weekend. Photo: Google. </span></div></div></a>
                <div class="jeg_post_category">
                    <span><a href="https://westsidetoday.com/featured/" class="category-featured">Featured</a></span>
                </div>
            </div>
            <div class="jeg_postblock_content">
                <h3 class="jeg_post_title">
                    <a href="https://westsidetoday.com/2019/11/05/lily-the-pink-helping-women-look-their-best/">Lily the Pink – Helping Women Look Their Best</a>
                </h3>
                <div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://westsidetoday.com/author/westsidetodaystaff/">Westside Today Staff</a></div><div class="jeg_meta_date"><a href="https://westsidetoday.com/2019/11/05/lily-the-pink-helping-women-look-their-best/"><i class="fa fa-clock-o"></i> November 5, 2019</a></div><div class="jeg_meta_comment"><a href="https://westsidetoday.com/2019/11/05/lily-the-pink-helping-women-look-their-best/#respond" ><i class="fa fa-comment-o"></i> 0</a></div></div>
                <div class="jeg_post_excerpt">
                    <p>Sandy Allbright’s permanent makeup studio in Brentwood&nbsp; By Staff Writer For women who want to look their best all the...</p>
                    <a href="https://westsidetoday.com/2019/11/05/lily-the-pink-helping-women-look-their-best/" class="jeg_readmore">Read more</a>
                </div>
            </div>
            </article>
            <div class="jeg_posts_wrap">
                <div class="jeg_posts jeg_load_more_flag">
                    <article class="jeg_post jeg_pl_md_1 post-130882 post type-post status-publish format-standard has-post-thumbnail hentry category-crime-courts category-culver-city category-featured category-news tag-ccfd tag-ccpd tag-culver-city tag-culver-city-fire-department tag-culver-city-news tag-culver-city-police-department tag-hit-and-run">
                <div class="jeg_thumb">
                    
                    <a href="https://westsidetoday.com/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/"><div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://westsidetoday.com/wp-content/plugins/epic-news-element/assets/img/jeg-empty.png" class="attachment-epic-120x86 size-epic-120x86 lazyload wp-post-image" alt="Fatal Hit and Run Occurs in Culver City" data-src="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM-120x86.png" data-sizes="auto" data-srcset="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM-120x86.png 120w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM-350x250.png 350w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-8.39.13-AM-750x536.png 750w" data-expand="700" /><div class="ccfic"><span class="ccfic-text">The area of Washington Place, west of Frances Avenue, where a fatal hit and run occurred over the weekend. Photo: Google. </span></div></div></a>
                    <div class="jeg_post_category">
                        <span><a href="https://westsidetoday.com/news/crime-courts/" class="category-crime-courts">Crime + Courts</a></span>
                    </div>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://westsidetoday.com/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/">Fatal Hit and Run Occurs in Culver City</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://westsidetoday.com/2019/11/05/fatal-hit-and-run-occurs-in-culver-city/" ><i class="fa fa-clock-o"></i> November 5, 2019</a></div></div>
                </div>
            </article><article class="jeg_post jeg_pl_md_1 post-130886 post type-post status-publish format-standard has-post-thumbnail hentry category-edify-tv category-featured category-news">
                <div class="jeg_thumb">
                    
                    <a href="https://westsidetoday.com/2019/11/05/edify-tv-dog-o-ween/"><div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://westsidetoday.com/wp-content/plugins/epic-news-element/assets/img/jeg-empty.png" class="attachment-epic-120x86 size-epic-120x86 lazyload wp-post-image" alt="Edify TV: Dog-O-Ween" data-src="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-3.08.50-PM-120x86.png" data-sizes="auto" data-srcset="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-3.08.50-PM-120x86.png 120w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-05-at-3.08.50-PM-350x250.png 350w" data-expand="700" /><div class="ccfic"><span class="ccfic-text">The area of Washington Place, west of Frances Avenue, where a fatal hit and run occurred over the weekend. Photo: Google. </span></div></div></a>
                    <div class="jeg_post_category">
                        <span><a href="https://westsidetoday.com/edify-tv/" class="category-edify-tv">Edify Tv</a></span>
                    </div>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://westsidetoday.com/2019/11/05/edify-tv-dog-o-ween/">Edify TV: Dog-O-Ween</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://westsidetoday.com/2019/11/05/edify-tv-dog-o-ween/" ><i class="fa fa-clock-o"></i> November 5, 2019</a></div></div>
                </div>
            </article><article class="jeg_post jeg_pl_md_1 post-130880 post type-post status-publish format-standard has-post-thumbnail hentry category-edify-tv category-featured category-news">
                <div class="jeg_thumb">
                    
                    <a href="https://westsidetoday.com/2019/11/04/new-hyatt-hotel-is-beginning-construction-at-culver-city-ivy-station-helms-bakery-district-fashion-sample-sale-westside-today-news-show-november-4-2019/"><div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://westsidetoday.com/wp-content/plugins/epic-news-element/assets/img/jeg-empty.png" class="attachment-epic-120x86 size-epic-120x86 lazyload wp-post-image" alt="New Hyatt hotel is beginning construction at Culver City Ivy Station, Helms Bakery district fashion sample sale: Westside Today News Show November 4, 2019" data-src="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-04-at-2.19.52-PM-120x86.png" data-sizes="auto" data-srcset="https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-04-at-2.19.52-PM-120x86.png 120w, https://westsidetoday.com/wp-content/uploads/2019/11/Screen-Shot-2019-11-04-at-2.19.52-PM-350x250.png 350w" data-expand="700" /><div class="ccfic"><span class="ccfic-text">The area of Washington Place, west of Frances Avenue, where a fatal hit and run occurred over the weekend. Photo: Google. </span></div></div></a>
                    <div class="jeg_post_category">
                        <span><a href="https://westsidetoday.com/edify-tv/" class="category-edify-tv">Edify Tv</a></span>
                    </div>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://westsidetoday.com/2019/11/04/new-hyatt-hotel-is-beginning-construction-at-culver-city-ivy-station-helms-bakery-district-fashion-sample-sale-westside-today-news-show-november-4-2019/">New Hyatt hotel is beginning construction at Culver City Ivy Station, Helms Bakery district fashion sample sale: Westside Today News Show November 4, 2019</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://westsidetoday.com/2019/11/04/new-hyatt-hotel-is-beginning-construction-at-culver-city-ivy-station-helms-bakery-district-fashion-sample-sale-westside-today-news-show-november-4-2019/" ><i class="fa fa-clock-o"></i> November 4, 2019</a></div></div>
                </div>
            </article><article class="jeg_post jeg_pl_md_1 post-130874 post type-post status-publish format-standard has-post-thumbnail hentry category-culver-city category-featured category-news">
                <div class="jeg_thumb">
                    
                    <a href="https://westsidetoday.com/2019/11/04/culver-city-firefighters-movember/"><div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://westsidetoday.com/wp-content/plugins/epic-news-element/assets/img/jeg-empty.png" class="attachment-epic-120x86 size-epic-120x86 lazyload wp-post-image" alt="Culver City Firefighters Movember" data-src="https://westsidetoday.com/wp-content/uploads/2019/11/CCFD-Firefighters-120x86.jpg" data-sizes="auto" data-srcset="https://westsidetoday.com/wp-content/uploads/2019/11/CCFD-Firefighters-120x86.jpg 120w, https://westsidetoday.com/wp-content/uploads/2019/11/CCFD-Firefighters-350x250.jpg 350w" data-expand="700" /><div class="ccfic"><span class="ccfic-text">The area of Washington Place, west of Frances Avenue, where a fatal hit and run occurred over the weekend. Photo: Google. </span></div></div></a>
                    <div class="jeg_post_category">
                        <span><a href="https://westsidetoday.com/culver-city/" class="category-culver-city">Culver City</a></span>
                    </div>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://westsidetoday.com/2019/11/04/culver-city-firefighters-movember/">Culver City Firefighters Movember</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://westsidetoday.com/2019/11/04/culver-city-firefighters-movember/" ><i class="fa fa-clock-o"></i> November 4, 2019</a></div></div>
                </div>
            </article>
                </div>
            </div>
                <div class='module-overlay'>
                <div class='preloader_type preloader_dot'>
                    <div class="module-preloader jeg_preloader dot">
                        <span></span><span></span><span></span>
                    </div>
                    <div class="module-preloader jeg_preloader circle">
                        <div class="epic_preloader_circle_outer">
                            <div class="epic_preloader_circle_inner"></div>
                        </div>
                    </div>
                    <div class="module-preloader jeg_preloader square">
                        <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                    </div>
                </div>
            </div>
            </div>
            <div class="jeg_block_navigation">
                <div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div>
                
                
            </div>
                
                <script>var epic_module_130882_1_5dc3153b3894f = {"header_icon":"","first_title":"","second_title":"","url":"","header_type":"heading_6","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","number_post":"5","post_offset":"0","unique_content":"disable","include_post":"","exclude_post":"","include_category":"","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","excerpt_length":"20","excerpt_ellipsis":"...","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":"4","pagination_scroll_limit":"0","boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"normal","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_1o3","class":"epic_block_13"};</script>
            </div></div>    </div>
  </div>
        <!-- end -->
      </div>
    <!-- end -->

  </article></div>
</main>

<div class="footer-ad"> 
  <script src='https://www.googletagservices.com/tag/js/gpt.js'>
  googletag.pubads().definePassback('/21621973880/westsidetoday_footertop', [[468, 60], [300, 250], [970, 90]]).display();
</script>
  </div>

<footer id="footer" class="bg-black">
  <div class="container f-text py-5">
  
    	  <div class="logo f-meta l-black pt-3 px-3 p-lg-0" itemscope="" itemtype="https://schema.org/Organization">
                                <div itemscope="" itemtype="https://schema.org/ImageObject">
                  <a href="https:/westsidetoday.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="300" height="99"   alt="WestsideToday" itemprop="logo" data-src="https://westsidetoday.wpengine.com/wp-content/uploads/2019/08/cropped-wst-logo-300x41.png" class="custom-logo lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="><noscript><img width="300" height="99" src="https://westsidetoday.wpengine.com/wp-content/uploads/2019/08/cropped-wst-logo-300x41.png" class="custom-logo" alt="WestsideToday" itemprop="logo"></noscript></a>                </div>
                            <meta itemprop="name" content="WestsideToday">
            </div>


        <div class="f-meta text-uppercase"><div class="d-inline-block border-top border-bottom p-3  c-white l-white">
      <div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-130567" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130567"><a href="/">Home</a></li>
<li id="menu-item-130690" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-130690"><a href="https://westsidetoday.com/advertising/">Advertising</a></li>
<li id="menu-item-130692" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-130692"><a href="https://westsidetoday.com/pr-services/">PR Services</a></li>
<li id="menu-item-130693" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130693"><a href="https://watchedify.com">WATCH EDIFY</a></li>
<li id="menu-item-130691" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-130691"><a href="https://westsidetoday.com/contact-us/">Contact Us</a></li>
</ul></div>    </div></div>
        
             <div class="d-flex justify-content-center">
        <div class="w-social d-none h5 c-meta l-meta"><ul id="menu-social-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9"><a href="https://www.facebook.com/WestsideToday/">facebook</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130566"><a href="https://twitter.com/westsidelatoday?lang=en">twitter</a></li>
</ul></div>      </div>
    
    <p class="m-0 pt-3 pb-4 f-text font-italic c-meta small">
      © 2019 WestsideToday    </p>
    <p class="m-0 pt-3 pb-4 f-text font-italic c-meta small">
		Made with ❤️ by <a style="color: black;" href="https://enki.tech">ENKI Tech</a>

    </p>

  </div>
</footer>


</div>
</div>
<script type='text/javascript' src='https://westsidetoday.com/wp-content/plugins/constant-contact-forms/assets/js/ctct-plugin-frontend.min.js?ver=1.6.1'></script>
<script type='text/javascript'>
window.lazySizesConfig = window.lazySizesConfig || {};

window.lazySizesConfig.lazyClass    = 'lazyload';
window.lazySizesConfig.loadingClass = 'lazyloading';
window.lazySizesConfig.loadedClass  = 'lazyloaded';

lazySizesConfig.loadMode = 1;
</script>
<script type='text/javascript' src='https://westsidetoday.com/wp-content/plugins/wp-smushit/app/assets/js/smush-lazy-load.min.js?ver=3.2.4'></script>
<script type='text/javascript'>
lazySizes.init();
</script>
<script type='text/javascript' src='https://westsidetoday.com/wp-content/themes/balaton/assets/js/jquery.lazy.min.js'></script>
<script type='text/javascript' src='https://westsidetoday.com/wp-content/themes/balaton/assets/js/jquery.infinitescroll.min.js'></script>
<script type='text/javascript' src='https://westsidetoday.com/wp-content/themes/balaton/assets/js/jquery.sticky-kit.min.js'></script>
<script type='text/javascript' src='https://westsidetoday.com/wp-content/themes/balaton/assets/js/bootstrap.min.js'></script>
<script type='text/javascript' src='https://westsidetoday.com/wp-content/themes/balaton/assets/weart.js'></script>
<script type='text/javascript' src='https://westsidetoday.com/wp-includes/js/comment-reply.min.js?ver=5.2.3'></script>
<script type='text/javascript' src='https://westsidetoday.com/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=5.2.3'></script>
<script type='text/javascript' src='https://westsidetoday.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var epicoption = {"prefix":"epic_module_ajax_","rtl":"0","admin_bar":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://westsidetoday.com/wp-content/plugins/epic-news-element/assets/js/script.min.js'></script>
<script type='text/javascript' src='https://westsidetoday.com/wp-includes/js/wp-embed.min.js?ver=5.2.3'></script>
</body>
</html>